1

My computer had a major upgrade of distributions, and afterwards, the X server starts, but quits after a few seconds. There are no errors in /var/log/Xorg.0.log. The few warnings are about missing font dirs.

The last lines of Xorg.0.log, after unloading of libinput modules, are:

[    27.544] (II) NVIDIA(GPU-0): Deleting GPU-0
[    27.615] (II) Server terminated successfully (0). Closing log file.

xinitrc is in /etc/X11/xinit/, contents:

#!/bin/sh

# /etc/X11/xinit/xinitrc
#
# global xinitrc file, used by all X sessions started by xinit (startx)

# invoke global X session script
. /etc/X11/Xsession

What's the best way to debug this and make X start again?

It's a computer with Ubuntu Gnome and a NVIDIA Quadro 2000 graphics card. The monitor is attached to the DVI output of the NVIDIA card, nothing else to the other ports.

NVIDIA module gets loaded, also nouveau, modesetting, fbdev and vesa. The last ones get unloaded afterwards, there is a validated Metamode for NVIDIA: "DFP-0:nvidia-auto-select". Looks good to me, so why is it not starting the Xserver?

4
  • 1
    If you're using a login manager, check the log files for the login manager (eg /var/log/gdm or /var/log/lightdm). If you're using startx or the error happens after login, check $HOME/.xsession-errors. Feb 1 '18 at 19:53
  • 1
    /var/log/gdm is empty, but gdm3 is running. Still no X. Scratching my head here...
    – emk2203
    Feb 1 '18 at 20:21
  • Had the same error - uninstalled gdm3 and installed sddm installed. Worked right away... Really weird error! Sep 19 '18 at 8:33
  • Thanks for the information! That would fit the overall setting of "trouble after major upgrade". I hope it helps someone with the same, frustrating issue.
    – emk2203
    Sep 19 '18 at 10:21
0

I had this happen to me. Turns out it was because I was using the pam_access module in PAM and had to add gdm to /etc/security/access.conf as users allowed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.