2

i recently upgraded my parrot security OS from 3.7 to 3.11. The problem is when i boot into it, the os is not detecting keyboard inputs. Hence i cannot enter my password at login and access the system.

However i can access the root terminal from recovery mode.

The contents of /var/log/Xorg.0.log show mouse and keyboard disabled.

  1. what is the problem?
  2. which files am i looking for?
  3. what file do i need to update?

Parrot OS is based on debian platform.

contents of Xorg.0.log

[    78.543] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[    78.547] X Protocol Version 11, Revision 0
[    78.549] Build Operating System: Linux 4.9.0-5-amd64 x86_64 Debian
[    78.550] Current Operating System: Linux parrot 4.9.0-parrot18-amd64 #1 SMP Parrot 4.9.18-1parrot18 (2017-04-23) x86_64
[    78.550] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.9.0-parrot18-amd64 root=UUID=5c770719-f7be-4f96-b3ae-0694e4e47f5d ro single noautomount
[    78.553] Build Date: 26 January 2018  04:30:21PM
[    78.554] xorg-server 2:1.19.6-1 (https://www.debian.org/support) 
[    78.556] Current version of pixman: 0.34.0
[    78.558]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[    78.558] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    78.564] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Feb  7 09:03:03 2018
[    78.564] (II) Loader magic: 0x55622c77ede0
[    78.564] (II) Module ABI versions:
[    78.564]    X.Org ANSI C Emulation: 0.4
[    78.564]    X.Org Video Driver: 23.0
[    78.564]    X.Org XInput driver : 24.1
[    78.564]    X.Org Server Extension : 10.0
[    78.565] (--) using VT number 2

[    78.565] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    78.565] (II) xfree86: Adding drm device (/dev/dri/card0)
[    78.565] (II) xfree86: Adding drm device (/dev/dri/card1)
[    78.581] (--) PCI:*(0:0:2:0) 8086:191b:103c:80a9 rev 6, Mem @ 0x92000000/16777216, 0xa0000000/268435456, I/O @ 0x00005000/64, BIOS @ 0x????????/131072
[    78.581] (--) PCI: (0:1:0:0) 10de:139a:103c:80a9 rev 162, Mem @ 0x93000000/16777216, 0x80000000/268435456, 0x90000000/33554432, I/O @ 0x00004000/128
[    78.685] List of video drivers:
[    78.690]    nvidia
[    78.694]    modesetting
[    78.694] (II) LoadModule: "nvidia"
[    78.700] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    78.773] (II) Module nvidia: vendor="NVIDIA Corporation"
[    78.773]    compiled for 4.0.2, module version = 1.0.0
[    78.773]    Module class: X.Org Video Driver
[    78.781] (II) LoadModule: "modesetting"
[    78.781] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    78.791] (II) Module modesetting: vendor="X.Org Foundation"
[    78.791]    compiled for 1.19.6, module version = 1.19.6
[    78.791]    Module class: X.Org Video Driver
[    78.791]    ABI class: X.Org Video Driver, version 23.0
[    78.792] (II) NVIDIA dlloader X Driver  387.34  Tue Nov 21 01:38:22 PST 2017
[    78.792] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    78.792] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    79.076] (++) Using config file: "/root/xorg.conf.new"
[    79.078] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    79.100] (==) ServerLayout "X.org Configured"
[    79.100] (**) |-->Screen "Screen0" (0)
[    79.100] (**) |   |-->Monitor "Monitor0"
[    79.101] (**) |   |-->Device "Card0"
[    79.101] (**) |-->Screen "Screen1" (1)
[    79.101] (**) |   |-->Monitor "Monitor1"
[    79.101] (**) |   |-->Device "Card1"
[    79.101] (**) |-->Input Device "Mouse0"
[    79.101] (**) |-->Input Device "Keyboard0"
[    79.101] (==) Automatically adding devices
[    79.101] (==) Automatically enabling devices
[    79.101] (==) Automatically adding GPU devices
[    79.122] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    79.153] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    79.153]    Entry deleted from font path.
[    79.157] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    79.157]    Entry deleted from font path.
[    79.157] (**) FontPath set to:
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    built-ins,
    /usr/share/fonts/X11/misc,
    /usr/share/fonts/X11/100dpi/:unscaled,
    /usr/share/fonts/X11/75dpi/:unscaled,
    /usr/share/fonts/X11/Type1,
    /usr/share/fonts/X11/100dpi,
    /usr/share/fonts/X11/75dpi,
    built-ins
[    79.157] (**) ModulePath set to "/usr/lib/xorg/modules"
[    79.157] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    79.157] (WW) Disabling Mouse0
[    79.157] (WW) Disabling Keyboard0
[    79.184] (II) Loading sub module "fb"
[    79.184] (II) LoadModule: "fb"
[    79.184] (II) Loading /usr/lib/xorg/modules/libfb.so
[    79.204] (II) Module fb: vendor="X.Org Foundation"
[    79.205]    compiled for 1.19.6, module version = 1.0.0
[    79.205]    ABI class: X.Org ANSI C Emulation, version 0.4
[    79.205] (II) Loading sub module "wfb"
[    79.205] (II) LoadModule: "wfb"
[    79.205] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    79.219] (II) Module wfb: vendor="X.Org Foundation"
[    79.219]    compiled for 1.19.6, module version = 1.0.0
[    79.219]    ABI class: X.Org ANSI C Emulation, version 0.4
[    79.220] (II) Loading sub module "ramdac"
[    79.220] (II) LoadModule: "ramdac"
[    79.220] (II) Module "ramdac" already built-in
[    79.231] (WW) Falling back to old probe method for modesetting
[    79.232] (EE) 
[    79.236] (EE) Backtrace:
[    79.238] (EE) 0: /usr/lib/xorg/Xorg (xorg_backtrace+0x4d) [0x55622c4f3e3d]
[    79.239] (EE) 1: /usr/lib/xorg/Xorg (0x55622c33c000+0x1bbbd9) [0x55622c4f7bd9]
[    79.241] (EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7ff8a7429000+0x12160) [0x7ff8a743b160]
[    79.242] (EE) 
[    79.243] (EE) Segmentation fault at address 0x0
[    79.245] (EE) 
Fatal server error:
[    79.247] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    79.249] (EE) 
[    79.250] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    79.255] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    79.256] (EE) 
[    79.258] (EE) Server terminated with error (1). Closing log file.
  • Guys any solutions, I really need to get access to the system. My projects are in it. – hardeep Feb 3 '18 at 8:42
0

Dmesg, check it out to see what it says. If there is a hardware error it should be there.

dmesg | less

But that's a classic, right?

Have you also checked /var/log/messages ?

  • What am I looking for in messages? – hardeep Feb 3 '18 at 16:50
  • I have added contents of xorg.log . Have a look. its showing mouse and keyboard disabled. – hardeep Feb 7 '18 at 6:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.