1

I'm using a Microsoft wireless keyboard+mouse combo and I mainly use Arch Linux.

Whenever I boot MS Windows on my computer, when going back to Linux, my mouse scroll wheel is insanely fast.

Apparently, this is a common issue, as is also widely known (1) (2) (3) (4) that unplugging the usb receiver and plugging it again will solve the problem. I can confirm this works. Upon search, we can see that this is not restrict to Microsoft hardware, but Logitech and others as well.

The question is WHY? What is the explanation?

I use full disk encryption for my Linux system, including the boot partition. This rules out the hypothesis that Windows is interfering with Linux.

0
1

The problem is that Microsoft mice need to be reset when you dual boot between Windows and Linux... This is a known issue, and there is even a utility to fix it...

This program basically just resets a setting in the mouse through usb communication and then exits.

https://sourceforge.net/projects/resetmsmice/

Search "resetmsmice" and your distro, and there's probably a package already made to fix this ;-)

Arch Package: https://aur.archlinux.org/packages/resetmsmice

screenshot of resetmsmice

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.