0

This is a fresh install of kali 2017.3 64 bit on virtual box. I am trying to install the terminator terminal.

**This is my sources.list:**

# 

# deb cdrom:[Debian GNU/Linux 2017.3 _Kali-rolling_ - Official Snapshot amd64 $

#deb cdrom:[Debian GNU/Linux 2017.3 _Kali-rolling_ - Official Snapshot amd64 L$

deb http://http.kali.org/kali kali-rolling main non-free contrib
# deb-src http://http.kali.org/kali kali-rolling main non-free contrib





**Attempt to install terminator:**

root@kali:~# apt-get install terminator
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  gir1.2-keybinder-3.0 libkeybinder-3.0-0 python-gi-cairo python-psutil
Suggested packages:
  python-psutil-doc
The following NEW packages will be installed:
  gir1.2-keybinder-3.0 libkeybinder-3.0-0 python-gi-cairo python-psutil
  terminator
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 833 kB of archives.
After this operation, 3,337 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Err:1 http://http.kali.org/kali kali-rolling/main amd64 libkeybinder-3.0-0 amd64 0.3.1-1
  404  Not Found
Err:2 http://http.kali.org/kali kali-rolling/main amd64 gir1.2-keybinder-3.0 amd64 0.3.1-1
  404  Not Found
Err:3 http://http.kali.org/kali kali-rolling/main amd64 python-gi-cairo amd64 3.24.1-5
  404  Not Found
Err:4 http://http.kali.org/kali kali-rolling/main amd64 python-psutil amd64 5.0.1-1+b1
  404  Not Found
Get:5 http://archive-7.kali.org/kali kali-rolling/main amd64 terminator all 1.91-1 [363 kB]
Fetched 363 kB in 1s (319 kB/s)    
E: Failed to fetch http://http.kali.org/kali/pool/main/k/keybinder-3.0/libkeybinder-3.0-0_0.3.1-1_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/k/keybinder-3.0/gir1.2-keybinder-3.0_0.3.1-1_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/p/pygobject/python-gi-cairo_3.24.1-5_amd64.deb  404  Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/p/python-psutil/python-psutil_5.0.1-1+b1_amd64.deb  404  Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?


**Attempt to update:**

root@kali:~# apt-get update
Get:1 http://archive-7.kali.org/kali kali-rolling InRelease [30.5 kB]
Err:1 http://archive-7.kali.org/kali kali-rolling InRelease
  The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
Fetched 30.5 kB in 0s (34.4 kB/s)
Reading package lists... Done
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://archive-7.kali.org/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/InRelease  The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
W: Some index files failed to download. They have been ignored, or old ones used instead.

I have followed tutorials in regards to updating the keyring and the sources.list file but nothing seems to work. Also, I have tried installing terminator from the source and I get the same errors.

  • 1
    Please include your error message in the question, not as images. – DavidPostill Feb 3 '18 at 17:06
  • Edited and fixed. – John Smith Feb 3 '18 at 17:30
0

I used this link: https://linux-audit.com/how-to-solve-an-expired-key-keyexpired-with-apt/

specifically: apt-key adv --keyserver keys.gnupg.net --recv-keys ED444FF07D8D0BF6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.