0

So My host OS is Windows 7 and the guest is an Ubuntu Server machine. I have connection between the host and the guest, but the guest cannot connect to internet, and I need to have both. I use a laptop with wifi connection and I have disabled Windows7 firewall.

I have configured the Network Adapter as bridged adapter:

enter image description here

My network adapters configuration is:

auto lo
iface lo net loopback

auto eth0
iface eth0 inet dhcp

auto enp0s3
iface enp0s3 inet dhcp

I have configured enp0s3 because it appeared when I executed ifconfig -a. eth0 have no use.

  • If I use NAT, the VM can make a ping to the host, but the host doesn't seem to find the guest (I have tried doing ping with ip and hostname) and the guest cannot connect to internet (I tried to do a ping to www.google.com) – albert Feb 4 '18 at 18:51
  • using the bridge mode the VM should get from the DHCP an IP address in the same class of the host, thus needing the same Gateway and DNS. Is that so in the Ubuntu machine? – Giovanni Valerio Feb 4 '18 at 23:31
2

This can be caused if your guest OS does not have an IPv4 IP assigned to it

run "ifconfig" to get the network details. If you do not see an inet4 address, try running "dhclient" to force a reassignment of inet4 address.

| improve this answer | |
0

The Bridged mode is for more advanced networking needs such as network simulations and running servers in a guest. When enabled, VirtualBox connects to one of your installed network cards and exchanges network packets directly, circumventing your host operating system's network stack.

Your virtual machine would network-wise be seen as a separate card in the network. For most usages this is not necessary. There might be reasons in your hosts network (outside your influence) for not recognizing or acknowledge your bridged network card.

It is safer (and recommended, unless you have quite special needs) to use NAT mode, which should work out-of-the-box in any networked environment.

https://www.virtualbox.org/manual/ch06.html#networkingmodes

| improve this answer | |
  • I have tried it but I cannot connect to internet. Ping between guest->host work, host->guest doesn't work (Yes, it's strange) – albert Feb 4 '18 at 18:55
  • Have you tried the NAT mode and does that work? – Megapatch Feb 4 '18 at 19:42
  • Yes, I have tried – albert Feb 5 '18 at 8:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.