-1

So the title pretty much says it all...

I have a computer with 2 drives, a 256GB SSD and a 512GB HDD. I have my Windows 10 installation on the SSD and I partitioned the HDD to serve as my Ubuntu installation (I gave ubuntu like 80GB of space)

I wanted to remove it.

So I installed a recovery disk on a USB drive.

Deleted my ubuntu partition and extended the HDD volume.

Booted into the USB and started up command prompt.

Ran Bootrec /FixMBR (or bootrec.exe /fixmbr)

Rebooted and I get a Grub Rescue prompt.

I searched around the internet and found that apparently I should also run bootrec /fixboot... but anytime I try to do that, it gives me access denied.

I also followed this guide http://www.howto-connect.com/fix-bootrec-fixboot-access-denied-windows-10/

but I can't find an EFI folder in my C: drive (the one with my Windows OS on it)

What am I doing wrong? I've been at this for an 2 hours now and I don't understand how to fix this. I can't even just restore the windows OS or restore from a restore point because they give me errors like no windows installation found.

Btw this installation of windows 10 is one that I upgraded from Windows 8 so I have a Windows.old folder in my C: drive... not sure if that affects anything?

  • If UEFI you can boot Windows directly by choosing the Windows bootloader manager as the first boot entry at UEFI settings. No need to recover anything else. But if you're looking for an "EFI folder" in Windows, you don't understand UEFI (and you were following an outdated guide applicable only to legacy installs). EFI is a partition, not a folder, typically the first one in the drive, where all bootloaders reside. – user772515 Feb 5 '18 at 18:28
  • First of all, welcome to Super User! We are always glad to help, but we see a lot of questions from people who encountered problems when they tried to dual-boot Windows and Linux. From my perspective, it would be much better to utilize a free hypervisor (like VirtualBox or Hyper-V) and create a Linux virtual machine, instead. – Run5k Feb 5 '18 at 18:29
  • 1
    @Run5k I must be said that the problem isn't Linux or Windows or even the dual/multi boot. The problem is the lack of basic knowledge about partitions, OS requirements and, in this case, UEFI/Legacy modes and how to proceed. Such users shouldn't be installing/managing OSes before learning the basics. – user772515 Feb 5 '18 at 18:40
  • @MichaelBay so following the link to the guide I posted, it said to navigate to the EFI\Microsoft\Boot\ directory and run bootrec.exe /fixboot which I can't find in any of the listed volumes I selected. I am unsure what to do as fixboot keeps giving me access denied. – Harsh Baid Feb 5 '18 at 18:41
  • Again, if UEFI (and any factory installed Win8 or newer is in UEFI mode) just open UEFI settings and make the first boot Windows instead of Ubuntu. UEFI is what replaces BIOS and has the great advantage of allowing different OSes to boot independently. – user772515 Feb 5 '18 at 18:44
-1

So if anyone finds this... I figured it out... After trying several utilities and several options

booting from a windows recovery disk or windows install disk and launching command prompt, I ran bootsect /nt60 <drive name>: /mbr and it fixed it!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.