I have a Dell Inspiron 5559 laptop that I've had for a few years, dual-boot between Windows 10 and Linux Mint with no issues. I had to remove the hard drive for a test repair on someone else's computer, when I replaced it and tried booting into Windows 10, it loaded for 30 seconds and returned with a generic "Your PC ran into a problem and needs to restart," with the specific error "MEMORY MANAGEMENT." I can load into Mint normally, but not into Windows 10.

I've troubleshot everything I can think of:

  • Restarted and drained the CMOS battery
  • Ran hardware diagnostics and a memory tester from an Ubuntu Live CD, all good
  • Swapped out both memory modules with like-specs, no change
  • Swapped out the hard drive and tried to install/boot from a Win10 USB I have with the same error
  • Remade the USB and used someone else's USB with no change

Everything I can look up on Google wants me to download some software or run a memory tester program from Windows, which I can't do since it won't load Windows, install stick or not, and Linux says it's working fine. Not sure if the issue is both of the install sticks I'm using or some hardware issue that Linux is overlooking. Everything on the drive is backed up on the cloud, so I'm not worried about losing data; I just want Windows back on this laptop.

Any suggestions?

EDIT: BSOD screen is as follows: Your PC ran into a problem and needs to restart. We'll restart for you. For more information about this issue and possible fixes, visit https://www.windows.com/stopcode If you call a support person, give them this info: Stop code: MEMORY MANAGEMENT

There's also a QR code that takes me to the website listed above.

  • 1
    Please edit and post the actual error message.
    – user772515
    Feb 5, 2018 at 19:01
  • @MichaelBay error message posted, about as generic as it gets Feb 5, 2018 at 20:25
  • So no actual error code, typically 0x(something)? And does the same error happens when booting from the installer? Or it's actually not booting from it and then falling back to the installed OS (where the error occurs)?
    – user772515
    Feb 6, 2018 at 11:34
  • @MichaelBay no error code, same error when booting from local boot manager and external installer Feb 12, 2018 at 22:08


You must log in to answer this question.