6

I'm having problems with my SSD (samsung 850 PRO) on linux so I wanted to update the firmware. I reinstalled windows and downloaded the magician software. It recognizes my SSD, I can run some benchmarks, but there's a message saying "this drive is not supported".

I've then gone into the samsung's website to download the firmware updater. It gives me an ISO file that I should burn using uNetBooting onto a pen drive (it says that this is a firmware update through windows, but it actually is a linux image that will run in the pen drive and do the update, I guess).

Anyways, I've burned the ISO into the pen drive and it didn't boot. I tried UEFI and non UEFI, but nothing happens.

I also tried to burn using dd, and it also didn't work (I didn't mess with the USB's partitions, filesystems etc though. Is there a needed one?)

7

You need to use ISO image from https://www.samsung.com/semiconductor/minisite/ssd/download/tools/ under header "Samsung SSD Firmware Updates for Windows Users". Don't be fooled by the "Windows users" label, the links to go to standalone ISO images which you can either burn to CD or DVD disk or follow the Samsung firmware install guide and convert the ISO image into bootable USB drive using unetbootin software (available from Ubuntu/Debian universe repository).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.