2

I manage my IMAP email account with Evolution.

I would like to synchronize locally all folders and emails of this account for offline work and backup purposes.

I checked "Synchronize remote mail locally in all folders" on the account setting AND, for each folders, checked "COpy content of the folder in local for offline operations" (sorry if the translation is not accurate, Evolution is configured in french).

Despite theses, my emails are not all synced when i disconnect evolution (button with plug at the bottom left). It asks me if i want to synchronize all folders, then do a quick operation and once disconnected i can't open most of my mails, a message is displayed said:

The message is not available in offline mode 

This can be due to the message not being downloaded yet. The folder, 
or the account, can be marked for offline synchronization. Then, once 
the account is online again, use File->Download Messages for Offline 
Usage, when this folder is selected, to make sure that all the 
messages in the folder will be available in offline mode.

It seems only the selected folder is syncronized.

Of course this is the same if i click on File > download messages for offline usage (once again the translation can not be accurate).

I use Evolution 3.18.5.2, Ubuntu 16.04.3 LTS

Do i miss something? is it a bug ?

0

This is the default behaviour in Thunderbird (saving messages locally when they are view).

I supposed the global configuration of evolution is not well-configured to retrieve mails when they are view. Maybe you should check entire inbox (or all folders) to be viewable in offline mode

Also on linux, you can user IMAP-sync for backup purposes.

  • Thanks for answer. I supposed this as well. I already checked an option "Synchronize remote mail locally in all folders" (displayed as it as it is not french translated) in the account settings, hoping this apply to all folders but this option has no effects. I checked the options in the inbox folder too (all my IMAP folders are subfolders of this) but there not seems to be recursive. If i don't find any solutions using Evolution i will take a look at IMAP-sync, or offlineIMAP. – sgt-hartman Feb 6 '18 at 10:58
0

This a bug that seems to be fixed on more recents versions of Evolution. See Gnome Bugzilla Bug 793290.

Milan Crha suggested the following workaround:

  • Define "Check for new messages in all folders" on the receiving options of the account
  • Unset at least one of Trash or Junk folders as real folder.

I confirm it works for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.