2

I know that DPI scaling within Windows 10 is a much-debated subject. But it seems none of the answers I've found directly addresses my issue (which doesn't look that complicated).

As far as I understand, Windows 10 allows setting an individual scaling to each connected screen. One simply does that by selecting the right monitor in the display settings window and applying the desired custom scaling value to that particular monitor.

I'm using two screens: my laptop's integrated monitor which is a 14' screen with a 1920*1080 resolution and an external 22' screen with the same resolution.

Obviously, both screens shouldn't have the same scaling or else one of them would show very large (or very small) icons and texts. But whenever I try to set the scaling for one screen, windows automatically sets the same scaling to the other one. I may have a custom scaling of 100 % or 125 % on both screens but for all my efforts I can't get 125 % on the primary (smaller) screen and 100 % on the secondary (larger) screen. Whenever I change one setting, Windows will ask for me to log out and when I log back in the other will be changed too...

This is becoming very annoying. How can I get the expected behaviour?

I'm using Windows 10 Pro, version 1703 (10.0.15063.850). Please note that I do not want to let Windows automatically choose the scaling values (for reasons that are probably irrelevant to the question here).

Edit 1: A similar question was asked for Win 8 a few years ago. The most-voted answer basically says Microsoft's developers made a bad design choice and we're stuck with it. Another similar question was posted later about the Win 10 preview but as far as I can see no definite answer was provided. Yet, it seems generally accepted that Win 10 now features the individual scaling (for example see here, here or here).

Edit 2: After a brief exchange with Microsoft's support, I should add that the computer involved always stays "docked", i.e. I never disconnect the external monitor. I don't move applications from one monitor to the other either, the problem occurs as soon as I change the setting, log out and log in again.

  • Hm. I can personally confirm I've scaled independently before. Possibly a dumb question, but you are extending desktop across the monitors, right? i.e. they're not in "clone" mode? – Bob Feb 7 '18 at 13:54
  • Yes, I am in extended desktop mode. BTW I've got two laptops (Lenovo ThinkPad T470 both), same OS version, same scaling problem. – user236356 Feb 7 '18 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.