1

Following the failed attempt to install netgen from it's sourceforge repo, somebody suggested to install the latest version from ngsolve.org. I did try that and I got the infamous 0xc000007b error:

enter image description here

Which there are like a zillion pages out there and also here to solve. Common solutions include:

  1. reinstalling the app
  2. restarting the computer!!!
  3. installing the latest version of Microsoft Visual C++ Redistributable Package (x64)
  4. running the program as administrator!!!

I did try all and none solved the issue. In this SO post it has been suggested to use dependencywalker to pinpoint the missing dependencies. I opened the netgen.exe in dependencywalker and it gives me this message:

Error: At least one required implicit or forwarded dependency was not found. Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module. Error: A circular dependency was detected. Warning: At least one delay-load dependency module was not found.

and when I do profiling it gives me the message:

windows\core\console\open\src\host\srvinit.cpp(480)\ConhostV2.dll!00007FFBF89A17FB: (caller: 00007FFBF89B0628) ReturnHr(3) tid(2e3c) 80070032 The request is not supported. windows\core\console\open\src\server\devicecomm.cpp(153)\ConhostV2.dll!00007FFBF89ABA9D: (caller: 00007FFBF89A170D) ReturnHr(4) tid(2e3c) 800700E9 No process is on the other end of the pipe. Exited "CONHOST.EXE" (process 0x36A8) with code 0 (0x0).

I don't know what to do from here. I would appreciate if you could help me know what is the problem and how to solve it.

P.S. I have also reported the issue here in the netgen forum.

5
  • 1
    It never specifies which C++ package is missing. Often you have to install several before you find the one it wants :/
    – Tetsujin
    Feb 7 '18 at 11:20
  • I'm not following. so there are several versions and I have to install all? is a list of them? should I reinstall the app again too?
    – Foad
    Feb 7 '18 at 11:23
  • 1
    There's one every year or so, going back a decade. There's no compulsion to map to any given version, unfortunately - support.microsoft.com/en-gb/help/2977003/…
    – Tetsujin
    Feb 7 '18 at 11:30
  • 1
    this is STATUS_INVALID_IMAGE_FORMAT, so you mixed 32 and 64 bit dlls Feb 7 '18 at 16:27
  • how should I resolve this?
    – Foad
    Feb 7 '18 at 16:29
0

Presently Netgen 6.1 experimental 64-bit installs fine on Windows 7 Enterprise.

Python 3.5.4 64-bit should first be installed (available at the time of writing from https://www.python.org/ftp/python/3.5.4/python-3.5.4-amd64.exe, newer Python may or may not work, I've not tried it).

Having installed Python for Windows the path should be corrected. The path is edited by right clicking "computer" in the start menu on Windows 7 and then "properties" in the pop up menu and then "advanced system settings" and then clicking on "Environment Variables" and then looking for "Path" in the user variables (top list box).

Despite looking like a 64-bit install of Python (based on the installer exe name), 32- and 64-bit executables are present and Netgen is calling the 32-bit version not the 64-bit and that won’t fly. So we need to adjust the path. The relevant changes for me were editing the python parts of the path to read as

C:\Users\[user name]\AppData\Local\Programs\Python\Python35\Scripts\;C:\Users\[user name]\AppData\Local\Programs\Python\Python35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.