0

I know the ip address and mac address of 2 machines..They are both of linux flavours.One is connected to the internet using asianet isp another is connected to the internet usiing docomo hotspot.They seem to be connected to the two different subnets. there ifconfigs outputs are

  virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:30:e0:7a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

and another computers ifconfig output is

wlan0     Link encap:Ethernet  HWaddr 00:24:2b:33:db:1d  
          inet addr:192.168.43.109  Bcast:192.168.43.255  Mask:255.255.255.0
          inet6 addr: fe80::224:2bff:fe33:db1d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:161 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8237 (8.2 KB)  TX bytes:20663 (20.6 KB)

. is it possible connect two machine clients without knowing the router password.

  • It would probably be a whole lot simpler to just get Teamviewer. Punching through a router firewall is not a simple task, TV will do it for you, for free. – Tetsujin Feb 7 '18 at 17:11
  • Openvpn if you have control of one of the machines internet configuration. – Tim_Stewart Feb 7 '18 at 17:26
  • @Tim_Stewart - "without knowing the router password" ... no router access, no VPN, no port forwarding... no chance. – Tetsujin Feb 7 '18 at 17:43
0

The hosts you are trying to connect do not have a public internet address, but an internal intranet address (192.168). You need to configure the router to direct the incoming packets to one selected host in the intranet. That's NAT (Network Address Translation) and is a feature that every router has, even in home environments. But yes, you need the router password. Try admin/1234 or admin/admin or call your ISP. Plus you probably need to configure the firewalls of the router -if enabled- and the firewall of the computer, to open the ports that you want to use.

|improve this answer|||||
0

The problem here is that not only are you on two different networks, but both those networks are in a private IP range (192.168.x.x). So, you'll need to get both the public IP address and then set up port forwarding on the router.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.