1

I've recently installed NixOs and I would like way-cooler to be my compositor. What configuration do I need to enable in the Nix config file?

5
  • 1
    I suggest you scroll down on the page you linked to and read it properly. You will find a link to the NixOS package ...
    – DavidPostill
    Feb 7 '18 at 21:03
  • @DavidPostill yes I installed the package. However, when I try to run it directly I gives me errors about shared libraries. On Archlinux it runs flawlessly.
    – phodina
    Feb 7 '18 at 21:17
  • So what errors do you get? Telling us what actually happens might help someone tell you what you need to do.
    – Mokubai
    Feb 7 '18 at 21:18
  • And we are supposed to guess what those errors are? Please edit your question and explain properly what your issue is. And read How do I ask a good question? and What types of questions should I avoid asking?.
    – DavidPostill
    Feb 7 '18 at 21:19
  • Seems enabling xserver in the Nix config installs all the missing libraries. I now get black screen with a mouse. Which is exactly what I didn't want to do as to have a lot of dependencies in the system.
    – phodina
    Feb 7 '18 at 21:23
0

By looking at the source code you will be able to enable it in your configuration.nix by adding something along the lines of programs.way-cooler.enable = true. It's jsut not in the stable release, yet.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.