1

I've been having this issue for several months and have already posted this issue several times in other sites, but no one seems to have an answer. This has me pulling my hair out and it is interrupting workflow horrifically. I would like to solve this, and I'm hoping someone can at least point me in the right direction. That said, I'm quite tech literate, and have researched as much as I can into this issue before posting, so I'm hoping that with some help this can get resolved. I've compiled all the details that are relevant to the issue, and organized them here.

Symptoms

  • When double clicking on a file to open its contents in File Explorer, sometimes it will open a new window of the folder instead of opening in the same window, even though my preferences are set to open in the same window. Sometimes it even opens 2 new windows for the price of 1! On its own, this wouldn't be that big of an issue, but I believe it is a part of the larger problem which is listed next.
  • When opening items due to double clicking, or just opening files from the "open with" context menu, most of the time explorer.exe will crash. While the program is crashing and resetting, I am unable to alt-tab, change volume, or use the task bar. The desktop also refreshes and flickers briefly. Crashes will sometimes last over a minute, which really disrupts workflow (especially when I need to open a lot of files in succession).
  • Sometimes when saving items to anywhere explorer will crash.
  • Making a new folder in any directory (even on external disks) will cause Explorer to crash. Note that this probably rules out immediate hardware malfunction. Additionally, double clicking to have explorer unzip a .zip will cause a crash.

In summary, explorer seems to crash randomly when accessing a directory to read/write data from files. This is pretty broad, but that's all I can gauge from it.

Crash Log

Event Viewer lists the issue as EventID 1000. Most of the time the faulting module is windows.storage.dll, and other times it is ntdll.dll or DUI70.dll. Here is an example of one of the error logs:

Faulting application name: explorer.exe, version: 10.0.14393.1532, time stamp: 0x5965adb0
Faulting module name: windows.storage.dll, version: 10.0.14393.2007, time stamp: 0x5a49bcac
Exception code: 0xc000041d
Fault offset: 0x00000000001c4b17
Faulting process id: 0x13f0
Faulting application start time: 0x01d38afd8291a0be
Faulting application path: C:\WINDOWS\explorer.exe
Faulting module path: C:\WINDOWS\System32\windows.storage.dll

I did enable crash dumps for explorer at some point, but was unable to understand any of the data it provided. Here's some statistics about my computer in case that matters:

Microsoft Windows 10 Home
10.0.16299 Build 16299
HP Pavilion Notebook
AMD Quad-Core A10-8700P APU
AMD Radeon R6 (Laptop version)
8GB RAM

Previously I was having this issue before the Creators update, but as you'll see below, updating to the latest version of Windows did not solve the issue.

EDIT Here is a Crash Dump provided by explorer.exe after I enabled CrashDumps through registry: Crash Dump

Potential Solutions

Here is a list of everything I have tried to fix this issue. Keep in mind that none of the things listed have seemed to solve it, the issue still occurred.

  • Reset File Explorer Preferences
  • Cleared File Explorer History
  • Enabled "Launch Folder Windows in Separate Process"
  • Ran netsh winsock reset
  • Disabled Quick Access Folder viewing and File viewing
  • Cleared Quick Access history
  • Ran sfc scannow
  • Ran antivirus
  • Ran a windows file explorer support program (this detected several other "issues" and apparently fixed them but the issue persisted)
  • Booted in Safe Mode without Networking, issue persisted
  • Performed a Clean Boot without any startup programs or services, issue persisted
  • Deleted BagMRU and Bags subkeys in the Registry (which should've reset file explorer preferences per directory)
  • Restarted the explorer.exe process with Admin privileges
  • Updated BIOS to latest version
  • Updated Windows 10 to latest version
  • Disabled fast-boot
  • Ran ShellExView and disabled all non-Microsoft shell extensions
  • Ran Dism /Online CheckHealth, there were no hard disk errors

Here is a list of things I haven't tried that could fix the issue (but I'm hesitant to do because of their very nature).

  • Reinstall Windows 10?
  • Disable Microsoft Shell Extensions?!
  • Shift everything to a new Admin account?
  • Destroy computer?

Discussion

I've searched online for this issue and have found many, many articles of people having crashing problems. While some of them seem to be similar to mine, the details are actually quite different. And the fixes they have all given haven't worked as a result of that. For example, many people have issues where explorer.exe crashes on startup, but this isn't what I experience.

I have found one forum post which matches my problem exactly and you should check it out here. There are more logs and attempted fixes listed there, and the crash dumps and error warnings are all identical to what I'm experiencing. Yet there still wasn't a clear fix at the end of that post. It seems like creating a new user could solve the issue, but that still doesn't explain why the issue occurred in the first place. Additionally, it was hinted that the issue would return even after a new account was made.

I can see that my explorer.exe program was modified by the latest Windows 10 update, as the creation date has changed. Yet the issue persists. So even with a completely new explorer.exe, the issue is still happening.

What I understand

I don't believe any service or actively running third party program is at fault here. After all, I ran a Clean Boot AND Safe Mode boot, and the issue seemed to persist. Could this in fact be an issue with the program explorer.exe data itself? Or some obscure setting in the User data? It's also likely not the fault of file corruption or virus interference, as the sfc scan AND CheckHealth yielded no results. Also, the problem occurs on external disks, which means it's unlikely that hard drive is at fault. Additionally, memory leakage doesn't seem to be the issue either. Drivers were all disabled during Safe Mode, so I don't think any updates are at fault. Could it possible that a virus or driver update somehow modifed a .dll and then stopped running? Does sfc scan to see if Windows files are intact? Is there a way to check such a thing? Could my user profile be corrupted? I'm just throwing out ideas.

Thanks for any help you can provide.

  • 1
    Personally, taking what you've observed and tried, I'd backup and reinstall. I know that's a pain, but that's also an almost guaranteed solution. – music2myear Feb 7 '18 at 23:18
  • @music2myear If I try to reinstall Windows while keeping Apps and Data, then isn't it possible that if there's some corruption in my User profile then nothing will be solved? But that did give me an idea to check this. I'll try making a new User account, test if the problem still occurs, and report back. – RobProductions Feb 8 '18 at 1:01
  • you said you use 16299, but crash shows you use 14393 which is anniversary update. create a dump and look at the dump with Windbg – magicandre1981 Feb 8 '18 at 16:16
  • @magicandre1981 as mentioned, I was having this issue previously before I updated to the latest version of Windows. The crash log was from before. I also mentioned that I tried to read the Crash Dump but I couldn't make sense of it. It gave me the stacktrace and I don't remember there being any useful data there, but I'll try again. – RobProductions Feb 9 '18 at 2:42
  • create and share the dumps. I'll try to analyze them – magicandre1981 Feb 9 '18 at 14:17
1

After several months of searching for solutions, I finally found something that can mediate the problem. I searched specifically for the faulting modules and the function listed in the Crash Dump info and ended up at this link which suggested a fix at the bottom. Here's the fix:

  • Navigate to Windows 10 Settings -> Personalization -> Start
  • Disable "Show recently opened items in Jump Lists on Start or the Taskbar"

It seems the issue resulted from some sort of error in adding an item to this recent list; hence why the crash occurs when creating a new folder or opening an item. One thing that hasn't been fixed is the "new window" part of the problem, but that's more of an inconvenience and I can work around that. At the very least, this seems to stop explorer from crashing... though I'm sure whatever the problem is it's still there, just mitigated by this setting. But that's good enough for me.

  • 1
    I always disable that function and so I never saw the issue on my sight. thanks for pointing out this workaround. – magicandre1981 Feb 11 '18 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.