1

Thunderbird’s Archived Messages feature allows to move mails into the "Archives" folder by clicking the Archive button or pressing the a key.

For some of my mails, this doesn’t work. For these mails, the button is greyed out and the key doesn’t do anything.

What could be the reason for this? How to fix it?

Example: I enable the Archived Messages feature for an email account that has 1200 mails in the inbox. I select all mails: the button is greyed out. I start from the top and select mails until the button is greyed out, go back one mail, archive, and repeat. From these 1200 mails, 32 can’t be archived.

I restarted Thunderbird, compacted the folder, and opened the mails, but it still doesn’t work. I also repaired the folder, didn’t help.

(Workaround: Moving the mails manually into the Archives folder works fine.)

1

I have the same problem with Thunderbird 60.6.1 (64-bit). For me buttons are not grayed out, but behaviour is the same: message is not archived. This is what I realised after a couple of hours of investigation.

Archiving options are bound to accounts/identities.

Account (default identity):

  1. Account Settings: abc@email.me
  2. Copies & Folders: Message Archives

Additional identity:

  1. Account Settings: abc@email.me
  2. Manage Identites…
  3. xyz@email.me: Edit…
  4. Copies & Folders: Message Archives

Now, since we have many "archiving strateges", one for each account/identity, Thunderbird should choose one. It chooses the one of the account/identity that matches the To: field (or archive in Local folders if none matches). If the IMAP folder cannot be reached the operation cannot be performed.

I have not found any documentation about it and Thunderbird gives no error message.

Several workarounds are possibile. For example, archive locally or archive on a server which is likely to be available. If you have stale unused accounts remove them (or rename them).

  • Your answer led me to the solution. In my case, I didn’t have multiple accounts, but multiple identities under one account. And each identity has its own 'Copies & Folders' setting. I edited your answer to include the solution for identities. – unor Apr 6 at 1:46
  • @unor, glad it was helpful and thanks for the editing. – Maurizio Pizzonia Apr 8 at 6:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.