7

I'm using VirtualBox Version 5.2.6 r120293 (Qt5.6.1).

Guest OS: Windows 7 Ultimate (32-bit)
Host OS: CentOS 7

I tried enabling bidirectional clipboard by going to Settings -> General -> Advanced and selecting Bidirectional form the dropdown menu for shared clipboard.

enter image description here

Then I restarted the machine. But it wasn't working.

I have already tried removing and adding the VM to the machine list. But the problem persists.

Any help would be appreciated.

  • 2
    Have you installed the Guest Additions on the Windows 7 guest? – n8te Feb 8 '18 at 7:21
  • @n8te I don't think so. Can you guide me to it? – Bilesh Ganguly Feb 8 '18 at 7:24
  • 1
    The guest additions are required to be able to use the bidirectional clipboard so that should be the cause of your issue if you don't remember installing it. See here. – n8te Feb 8 '18 at 7:27
  • @n8te Guest additions weren't installed. So, I installed that and the bidirectional clipboard started working. Thank you for the help. – Bilesh Ganguly Feb 8 '18 at 9:15
5

You need to add extension pack for you virtualbox

  1. Open https://download.virtualbox.org/virtualbox and open your Virtualbox version
  2. Download Oracle_VM_VirtualBox_Extension_Pack.vbox-extpack.
  3. Open Virtualbox VM Manager
  4. In File->Preferences, Select Extension
  5. Now add extension by browsing to download location

Done.

Not the answer you're looking for? Browse other questions tagged or ask your own question.