3

Up until recently (before Feb 4th 2018 fo sure) I was able to switch focus to the active Google Chrome windows or run the app if it is not running with:

open "/Applications/Google Chrome.app"

Now the same command opens new window of Google Chrome instead of switching to the existing one.

I do not understand why it happens and why it changed all of a sudden. I did nothing special in between so it must be due to automatic updates of Google Chrome. How can I achieve previous behaviour?

I of course also searched for a solution but did not find anything relevant. I have tried to run Chrome directly with:

$ /Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome

It gives the same result (opens new window) and I also got this message in the terminal:

Created new window in existing browser session.
[some strange numbers here:ERROR:browser_gpu_channel_host_factory.cc(121)] 
Failed to launch GPU process.

I do not understand this error but forums (e.g., here) suggest to do

export BROWSER=google-chrome

It did not work for me. So here I am asking for help)

(MacOS 10.13.3, Google Chrome Version 64.0.3282.119 installed with brew cask install google-chrome)

  • I have this problem too, I can't even hide the output with 2>&1 /dev/null or | grep "shutup" I am guessing chrome is finding any open terminal and printing to it somehow. – flcoder Feb 18 '18 at 3:19
  • 1
    @flcoder as a temporary solution try to toggle off Use hardware acceleration when available in Chrome settings. This solves the issue for me. – Stas Feb 19 '18 at 7:40
  • @Stas Thanks for the workaround. It also worked for me – user45909 Feb 19 '18 at 9:17

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.