0

So today I tried installing Ubuntu 17.10.1 alongside Windows, using the free tool called Wubi.

During the installation, my PC just randomly crashed, and booted into this GRUB-like shell.

And here are three problems that cause me to drive insane:

  • The BIOS won't read my USB keyboard until Windows is booted, I've tried USB 2.0 keyboards, USB 3.0 keyboards, nothing works. Even the DELETE and Esc buttons don't work so I have no ability to enter the BIOS menu.
  • Also, generic USB Flash Drives aren't being recognized, so there is no way for me to boot into an operating or Live Disk stored on the USB drive.
  • I have no PS/2 keyboard, not even a PS/2 port.

My question is: How do I enter the BIOS without a keyboard or USB device? Though, the trouble actually started when I disabled the Secure Boot option in the BIOS, but since I have no way to enter the BIOS, I cannot re-enable this feature.

I know that my hard drives are still intact, because I created a partition on my Data drive, which is NOT my normal boot drive (C:). So my files should be intact.

I hope there is a solution suitable for my problem.

P.S.: I also have no ability to type into the grub > prompt.

5
  • Enabling or disabling Secure Boot should not in any way affect the input devices. Explicitly disabling support for those in UEFI/BIOS is what does it, nothing else. And if you disabled it... Also Wubi is NOT to be used with any Windows 8 or newer and was never intend as a permanent solution but just a way to try Ubuntu. Proper installation in UEFI mode is done like this askubuntu.com/questions/221835/… – user772515 Feb 8 '18 at 20:48
  • Please add more information about your PC (model, BIOS). Which Wubi version did you use and which ISO did you use to install ? Your picture shows GNU GRUB version 1.98+20100804-5ubuntu2. It is the version from the outdated Ubuntu 10.10 !!! – ngng Feb 9 '18 at 11:39
  • @ngng I am sorry for the confusion, I downloaded a random picture on the internet which looked like my issue. I tried it with the latest stable version of Wubi with Ubuntu 17.10.1 – Kees van Voorthuizen Feb 9 '18 at 13:16
  • @ngng the model of my computer is an MSI Aegis 056-EU and the BIOS name is MSI Click Bios 5. – Kees van Voorthuizen Feb 9 '18 at 13:16
  • Your BIOS has a "Legacy USB Support" setting. I assume you disabled it unintendedly. As "Legacy USB Support" is enabled by default, answer of Allen Howard is a possible workaround. – ngng Feb 9 '18 at 20:34
1

Since you don't have any ability to type anything, you're pretty much out of luck.

The one thing you can try is to clear the CMOS settings, this should work as long as Secure Boot On is the default option. If you are using a desktop, this is generally done with a jumper on the motherboard. If you are using a laptop, you should find a coin-cell battery that, when disconnected, should clear CMOS.

5
  • Thank you very much, I will try this solution tomorrow. I searched the internet for this and this should be it. Though, is it safe to do this? Would this affect my hard drives in a negative way? – Kees van Voorthuizen Feb 8 '18 at 19:40
  • No, this won't touch anything on the hard drives. – Allen Howard Feb 8 '18 at 19:43
  • I was not able to locate a CMOS battery/jumper/button on my motherboard, since it’s completely hidden behind my GPU and I am afraid of touching it at all (it’s a pre-built pc) so my question was: yesterday I found a PS/2 port on the back of my pc, so what happens if I buy a PS/2 keyboard or some kind of converter? Will it be loaded before the bios/OS boots? Can I be able to press the DELETE button before the failed OS starts? – Kees van Voorthuizen Feb 10 '18 at 20:01
  • 1
    @Kees van Voorthuizen: Good news if you found a PS/2 port. Yes, of course, a PS/2 keyboard needs no "Legacy USB Support" or a special driver. – ngng Feb 11 '18 at 13:16
  • @ngng It completely solved my problem! I was able to press the DELETE key and I could get back to Windows. – Kees van Voorthuizen Feb 11 '18 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.