0

I don't know why and how but I can't write anything on my USB stick while being on Windows. I tried formatting it, it changed nothing. I also did the registery hack, it already was to 0.

I created a virtual machine with Linux and formatted the USB via gparted. No success at all.

BUT I'm able to read and write files on that stick through Linux (Ubuntu)...

What am I doing wrong ?

  • When you format USB from Linux it will automatically format in the ext4 file system which is not supported by Windows. Make sure that you choose NTFS or FAT32 file system. – Biku B. Feb 10 '18 at 14:08
  • It is in NTFS. I also tried FAT32, doesn't change anything. – user871363 Feb 10 '18 at 14:10
  • 1
    Sometimes Windows doesn't automatically assign the drive letter for the USB Drive. You can manually assign it from the disk management by typing diskmgmt.msc. You can also manually format your USB drive from there and if your USB drive is not listed there at all then it is different story. – Biku B. Feb 10 '18 at 14:11
  • Take a look : i.imgur.com/v6HAdDG.png – user871363 Feb 10 '18 at 14:18
  • It'd had been better if you took a full screenshot. – Biku B. Feb 10 '18 at 14:24
0

I can't undelete my post apparently... So here is a more extended answer :

So... I manged to fix my problem by doing this : https://www.tenforums.com/drivers-hardware/87515-pny-ssd-stuck-raw-file-system.html#post1062176

Because it wasn't obvious enough, the above steps does this :

Diskpart - Open the disk partition software of Microsoft
list disk - List all current disks (including my bugged USB)
select disk # - Allow me to select my bugged USB (# refer to the ID displayed with the previous command)
clean - remove everything from the USB (not really needed, since I can't write / remove files from it)
convert gpt - Convert the partition table, apparently, Windows like it that way.
create part pri - Create a primary partition (required)
format fs=ntfs quick - Quickly format the parition to NTFS format.
assign - Assign a letter, so it can be seen in Explorer.exe
exit - obvious
exit - obvious

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy