5

I tried disabling Windows Subsystem for Linux (WSL), Windows Defender Application Guard, and Hyper-V, but even THAT didn't work. I always disable virtualization to run Bluestacks, but now I need to enable virtualization for the new Bluestacks N version. I really want it, but Bluestacks keep saying that Hyper-V is enabled on my system and I have to review the FAQ to disable it. I also set hypervisorlaunchtype to off using bcdedit.

EDIT: Even Google's Android AVD manager reports the same thing!

3

2 Answers 2

5

Did you enable the Memory Integrity option in the Core Isolation menu on Windows Defender? This option is available on Windows 1709 and later. Try disabling it. Here's the pic:

memory integrity

And if you see that you can't disable it because of the lack of administrator rights, even though you're the owner of the administrator account, go to this registry directory in regedit:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\DeviceGuard\Scenarios\HypervisorEnforcedCodeIntegrity

Then go to the right side pane, double click on the Enabled, change its value data from 1 to 0 and click OK to save changes.

Hope this helps.

4
  • 2
    Core Isolation is a feature that was introduced with Windows 10 Version 1709 not Windows 10 Version 1803.
    – Ramhound
    May 18, 2018 at 10:58
  • 2
    Do we really need to disable all the Windows 10 features that use virtualization? I'm worried about attacks if I disable this. Jun 10, 2018 at 16:00
  • 4
    It is already disabled and I'm having the same issue as the questioner.
    – Unknow0059
    Jul 15, 2020 at 16:39
  • 2
    "It is already disabled and I'm having the same issue as the questioner." - I'm facing the same issue here.
    – Atiq Baqi
    Sep 12, 2020 at 5:27
0

Go to: Control Panel > Programs and Features > Turn Windows features on or off >
Disable "Virtual Machine Platform" and restart.

I had this same issue after installing WSL and turning off Hyper-V, so apparently you need to turn off more than just Hyper-V.

This bluestacks support article lists multiple things to disable in case it still isn't working for you:

  • Hyper V
  • Windows Hypervisor Platform
  • Windows Sandbox
  • Virtual Machine Platform
  • Windows Subsystem for Linux

Additional info:

For some specific editions of Windows 10, the "Virtual machine platform" and "Windows hypervisor platform" check-boxes are not available. If you don't see these options in the Windows features:

  1. In the windows search bar, search for "core isolation" and open it.
  2. In the core isolation settings, turn off the Memory integrity.

Note: If you can't interact with the "Memory integrity" switch, check this post: How can you turn Core Isolation Memory Integrity back off again in Windows 10 build 17127 and later

Not the answer you're looking for? Browse other questions tagged or ask your own question.