2

This is just documentation for a problem I ran into. I was creating a hybrid multiboot USB stick on 64-bit Ubuntu 16.04 using this Arch tutorial and the --target=i386-pc command gave me the following error:

grub-install: error: /usr/lib/grub/i386-pc/modinfo.sh doesn't exist

See answer for solution....

6

I looked up this file in the Ubuntu package archives and found it was part of the grub-pc-bin package. I tried to install that package, but it had bad dependencies.

However, since I knew I only needed those i386 modules, I just downloaded and unpacked the package, then moved the files into place manually like so:

cd /tmp
sudo apt-get download grub-pc-bin
dpkg-deb -R grub-pc-bin_2.02~beta2-36ubuntu3.16_amd64.deb grub/
sudo mv grub/usr/lib/grub/i386-pc/ /usr/lib/grub/

Now you should be able to try again and it should work.

(Note: Your apt-get download command may yield a file with a different version than the one shown. If you get errors on the dpkg-deb line, make sure you're targeting the file you just downloaded.)

  • For some unknown reason, my target was set as x86_64-efi platform was giving error for not finding efi directory. Then I changed target which gives this error. Now I used your answer to find the actual package – Anwar Jun 10 '18 at 10:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.