6

Everything was working fine until yesterday. Now, when I turned on my PC today and tried saving a text file written in Notepad, I am getting the following popup:

Click here for the screenshot.

Also, not just in saving txt files, I am having the same problem whenever I try to save images from photoshop or any files into the 'desktop'. However, everything just works fine when I try saving the same files in other drives. The problem occurs when I try saving the files in 'desktop', 'documents', 'pictures' or anything else that is a subfolder of C:\ drive. Morever, Microsoft Word or PDF files can be saved in the 'desktop' folder. Also, I can even download contents from the internet using Chrome directly to 'desktop'. The problem seems very crazy. I cannot simply figure out what's wrong with my PC.

Can anyone tell me the approach to fix this issue? I am thankful to you in advance.

[P.S: I am on Windows 10 OS v 1709.]

2
9

The problem has been solved. It was happening because I once turned on the Controlled Folder Access in Windows Defender which was by default turned off. I just opened the Windows Defender Security Center >> Virus and threat Protection >> Virus and threat Protection settings >> "TURNED OFF" the Controlled Folder Access option and it did my job. The problem was driving me nuts bdw. :(

2
  • 1
    I recently added all my drives to controlled folder access thinking it would help prevent unknown changes. Turns out it blocks all applications from changes! I was beating my head against the keyboard trying to figure out if my drive had bricked or not (stuck in read-only). This solved it. – Gaʀʀʏ Dec 28 '18 at 19:04
  • I have had more problems with windows defender in the past month than I have ever had with any anti-virus program to this date. I wonder what has changed? Could a windows update be the sudden cause of my anti-virus issues? Anyway thank you for pointing out my Windows Defender "controlled folder access" issue. My problem is now fixed and I am a very happy camper. – Rob Moore Feb 13 '19 at 18:50
3

Instead of disabling it completely. I just allow specific applicatons through.

  1. Click the windows button Windows icon

  2. Type "Windows Security" and click on "Windows Security App" Windows Security App icon

  3. Click "Virus &Threat protection"

    Virus and threat protection icon

  4. Scroll down (if necessary) and click "Manage ransomware protection"

    Ransomware protection icon

  5. Click "Allow an app through Controlled folder access"

    Allow an app through Controlled folder access

  6. Click "Yes" when the user account control pops up

  7. Click "Add an allowed app"

    Add an allowed app

  8. Choose between "Recently blocked apps" or "Browse all apps". I usually choose "Recently blocked apps"

  9. Click the plus icon next to the app you want to allow

    add icon

  10. Click the "Close" button

  11. Important: Restart the app if it was open. Otherwise it will not work (in my experience).

2
  • Any ideas how to allow a specific python script through, rather than python.exe, which would allow any arbitrary python script access. – toonarmycaptain Mar 2 '20 at 19:16
  • I think there was no option like this in the version that I used back then. – Sanu_012 Apr 24 '20 at 13:50
2

As detailed in this Microsoft Forum question, Microsoft (MS) Security Essentials can apparently interfere with saving items to certain special "controlled" folders. The solution to alleviate this issues is to:

  • From the Start Menu, select Settings. Click the Update and Security icon.

  • Choose Windows Defender from the list of items on the left. Scroll to the very bottom in the right-hand pane and then click the Open Windows Defender/Security Center link.

  • In the new window, select Protection from Virus and Threats > Virus and Threats Settings.

  • Turn off Access to Controlled Folders.

1
  • 1
    I did the same thing mate. Bdw voted ur answer as Correct. Cheers !! – Sanu_012 Feb 11 '18 at 10:35

Not the answer you're looking for? Browse other questions tagged or ask your own question.