0

I might have jumped off the deep end when getting back into Linux and am stuck trying to install a new version of Ruby on OpenSuse with rbenv.

me@linux-tzyj:~> rbenv install 2.4.0
Downloading ruby-2.4.0.tar.bz2...
-> https://cache.ruby-lang.org/pub/ruby/2.4/ruby-2.4.0.tar.bz2
Installing ruby-2.4.0...

BUILD FAILED (openSUSE Tumbleweed 20180209 using ruby-build 20171226-3-g01e7b7b)

Inspect or clean up the working tree at /tmp/ruby-build.20180211014832.4210
Results logged to /tmp/ruby-build.20180211014832.4210.log

Last 10 log lines:
The Ruby openssl extension was not compiled.
The Ruby readline extension was not compiled.
The Ruby zlib extension was not compiled.
ERROR: Ruby install aborted due to missing extensions
Try running `apt-get install -y libssl-dev libreadline-dev zlib1g-dev` to fetch missing dependencies.

I tried finding any of those in apt-get and zypper with no luck. Does OpenSuse handle these packages differently than Ubuntu does? That is what I used to use years ago.

I tried running zypper in -t pattern devel_basis but that just removed the zlib1g-dev in the list of missing packages

1

They are indeed slightly different. Try zypper install libopenssl-devel readline-devel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.