1

Note: I know there are several seeming duplicates for my question, but I have tried the suggestions in all of them with no luck as, in almost every case, I do not have the setting/file/tab/etc suggested!

Like many other Windows 10 users my touchpad (and mouse buttons) disable when typing. This is obviously completely undesirable as a gamer as it makes most games impossible. I would really appreciate a fix to this, be it in my computer or by downloading some kind of software or program that can fix it.

Specs

  • Sager NP8952 Notebook (approx 1mo old)
  • Windows 10 Home, version 1709
  • Synaptics SMBus TouchPad

Symptom

  • When holding down keys on the keyboard, the computer does not register touchpad or mouse button input

Attempted Solutions

One - Disable PalmCheck, SmartSense, etc

My laptop does not have a "ClickPad", "Synaptics", "DeviceSettings" or other touchpad-specific settings tab in the mouse page. Please see below: Mouse Properties Pane

Any guide saying to disable settings in the mouse pane won't work for me.

Two - Registry Edits

I saw this answer about changing your HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Defaults keys matching "PalmKms" to zero. I did, no changes. Registry

Three - Update / Change / Rollback Drivers

I have the 19.3.4.72 driver. I have tried a 18.x version with no luck. I uninstalled and reinstalled the entire device. Still no luck. I also have updated Windows to the latest version.

Four - Change Touchpad to Always On

I saw several posts about changing your Touchpad settings in the default Windows system settings, but I don't have the Touchpad: "No Delay (Always On)" dropdown menu, just the following and "Most Sensitive" still displays the issue. Touchpad

Conclusion

I'm out of ideas. Anyone have a suggestion on how to stop the touchpad disabling when clicking?

  • When the synaptic software is installed there is usually an icon in the notification tray to show that. You can adjust all the options of the touchpad from there. You didn’t indicate if you tried that. – Appleoddity Feb 11 '18 at 22:25
  • @Appleoddity Just checked, there's nothing in my task bar labeled Synaptic or anything that sounds touchpad related. I checked for disabled icons too. – Alex Feb 11 '18 at 22:27
1

The REGEdit solution works for me, however you must also click on SynTPCpl(Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTPCpl), and then set the value of "RestoreAllDefaults" to 0, and then also change the value of "Delete User Settings" to 0 in Synaptics\SynTP\Install(Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\Install), Then proceed to restart computer.

0

I "fixed" it by downloading an older driver (here, you might want to see if there is an older driver for your model on the Sager website).
It's definitely not ideal (it removes all the windows 10 integration from having a "precision touchpad").

The ideal answer would keep the newest driver.

I have an older laptop (Sager NP8640) but updating windows 10 to version 1709 caused the exact same problem, and none of the fixes you listed worked for me either (nor Mark's answer).

0

I think I found the solution. Go to Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Synaptics\SynTP\TouchPad and rewrite value of "PalmDetectConfig" to 0. Works for me! HP probook 440 G4

0

I think I solved it for you

It's funny cause I had the exact same problem on my Hp Pavilion laptop which took me hours to figure out. I tried reinstalling drivers, getting older drivers with the "No delay" option, Messing with my Device Manager,Control Panel and Commands 1000 times, checking for PalmCheck or SmartSense which I did not have, since the Synaptic Smbus ClickPad setting in mouse properties was removed somehow.

I tried many websites (Microsoft Support,Reddit,YouTube, etc.) but couldn't find the most suitable solution. I even tried contacting many Customer Support people from Hp and Microsoft, but that ended up being useless and I wasn't sure if they knew what they were up against. One guy tried controlling my laptop to see the problem and restarted it but that did nothing

So I finally decided to take matters onto my own hands. The link to the video that helped me the most: https://www.youtube.com/watch?v=yR11GxoN7vk&t=213s

SOLUTION: So first go onto Device Manager> Mice and other pointing devices, then find your synaptics driver and right click then click "Update driver". Next click on the "Browse my computer for driver software" then click "let me pick from available drivers" option and this will bring you to all your past drivers. I picked the PS/2 Compatible Mouse option but if your laptop dosn't have that as I've seen from your post then click HID compliant mouse. Then restart your computer and Voila!

But before you do this you may have to uninstall the Synaptic driver first but try it without uninstalling Synaptics just to be on the safe side 😉

0

Apparently you need to use a 17.x driver version to be able to completely turn off this feature, all subsequent versions of Synaptics will always disable the touchpad while typing on the keyboard (except the arrow keys). At the least, I can confirm that disabling SmartSense with a 17.x driver (but not with 19.x driver) works.

If all else fails, you can simply remove the Synaptics driver and use the default Windows driver, you will lose all nifty touchpad functionalities but the touchpad won't be locked anymore.

If you want to install an older driver version, you need to follow this procedure:

  1. find a 17.x or older driver for your laptop. For HP, you can try this one (maybe it can work for others?): http://ftp.hp.com/pub/softpaq/sp64001-64500/sp64284.exe
  2. uninstall your current Synaptics driver (and check the option to delete all drivers files, else the driver will be reinstalled automatically at next reboot).
  3. disconnect from Internet, this will prevent Synaptics from downloading a newer version of the driver from internet on install.
  4. reboot and install the old driver, all with internet switched off.
  5. reboot, open Synaptics configuration panel, disable SmartSense (move the slider all the way down), and test typing and moving the touchpad at the same time. If it works, you are almost done.
  6. to prevent Synaptics from updating the driver automatically, use this Windows patch: https://support.microsoft.com/en-gb/kb/3073930 (if the link goes down, the utility filename is: wushowhide.diagcab and is called the “Show or Hide Updates” troubleshooter).
0
  1. Go to Windows Settings > Devices > Touchpad
  2. Under Touchpad sensitivity set it to "Most sensitive"

Changes should go under effect immediately. This is what solved the issue for me.

Here's an image of where to go

0

To disable touch pad win 10 Go to Device Manager (Rt click on start) Expand "mice and other pointing devices Disable "Synaptics piniting device"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.