69

I've been using Chrome's built in bookmark sync which seems to work well.

Is there a way to force Chrome to do the sync as opposed to waiting for the alloted 'sync time'?


Update: Seems to sync when I restart Chrome, so that works. Would be nice to have a "sync button" equivalent..

4
  • related: superuser.com/questions/76408/…
    – cregox
    Mar 23, 2011 at 21:40
  • Did you change your password recently. That can mess things up I've found. Jun 19, 2011 at 3:40
  • 2
    A restart actually does not always force an update.
    – Asclepius
    Jan 25, 2015 at 23:15
  • 1
    How is this still not fixed! I've been waiting all day, tried everything on this list and gone through several computer restarts and it still isn't synchronizing. 5 years and this is still an issue? I don't get it.
    – aviemet
    May 10, 2016 at 2:05

9 Answers 9

31

Another way to make a change is to bookmark a new page and delete the bookmark. This will force chrome to sync the bookmarks.

3
  • 1
    Yes this worked for me! Much better solution! Thank you.
    – jackocnr
    Feb 25, 2012 at 21:31
  • Way better solution here!
    – mbb
    May 2, 2012 at 17:35
  • 1
    For those of you impatient like me, this DOES work, it just takes a couple minutes. (literally 2 minutes for me)
    – trex005
    Nov 15, 2016 at 8:58
20

This is a way to force sync of all Chrome Sync features manually.

Go to Settings > Extensions, click to check Developer mode if it is not already enabled, and then click the Update extensions now button.

At this point, a sync occurs immediately for extensions, bookmarks and all Chrome Sync features. You may then check from your chrome address bar the chrome://sync/ page and observe on Local State / Last Synced, it should say "Just now".

4
  • 4
    One can alternatively check the sync status at google.com/settings/chrome/sync. It shows the "Last time synced".
    – Asclepius
    Jan 25, 2015 at 23:16
  • 1
    Although the technique in this answer has worked for me in the past, it is not reliable. It did not work for me today, at all.
    – Asclepius
    Apr 7, 2015 at 23:23
  • 1
    Seeing this, I finally feel confidient that Chrome have really synchronized my bookmarks. I have once lost my bookmarks added in three months sometimes ago.
    – zwcloud
    Jan 7, 2018 at 8:30
  • chrome://sync/ and chrome://sync-internals/ both go to the same page. The page's name is "Sync Internals". This page shows a wealth of information that can help you to understand more how syncing works. I would NOT recommend clicking any buttons or settings on this page unless you know what you are doing! Simply closing and reopening the browser worked for me to sync my bookmarks and I didn't have to try any of the other ideas here. Another page that is useful to see a list of your synced items and counts and your current sync status is: chrome.google.com/sync
    – theMaxx
    May 30, 2020 at 8:37
13

You'll have to manually log out and log back in.

In Google Chrome Options, in Bookmark sync section: Click: Bookmarks Synced -> Stop Syncing this account.

Then in Bookmark sync section: Click: Synchronize my bookmarks. And log back into your Google account.

"Last synced" should then be updated to "Just now".

9

I found that when, in Advanced Sync settings, synch everything was set that Bookmarks sync showed as "disabled by user"

When looked at the debug info, (Type this into chrome: )

chrome://sync/

If you see that bookmark synching is disabled then, in Advanced Sync settings, you can switch synch everything to choose what to sync and then uncheck bookmarks , save , and then re-check bookmarks.

2

This is an old question, but I did find it here from googling this exact problem, so let me share what I found:

When I typed chrome://sync into the Chrome search bar, the browser suggested chrome://sync-internals. And sure enough, the Trigger GetUpdates button (near the top and 3/4 of the way to the right of the page) seems to trigger sync.

Hope this helps!

1

In settings click Manage your synced data with GOOGLE DASHBOARD. Check number of synced bookmarks. Than add new one. Check again in the same way. If number is changed than your sync is up to date, and you can safely reinstall windows/chrome or whatever are you doing.

1

Just had the same problem. I opened my chrome browser on my mobile device, went into settings and clicked on my email address. It opens the Services window and I clicked on Sync then turned it off, backed out then went back in and turned it back on. I had to sign back into chrome at that time and after that everything was updated from bookmarks I had just deleted and added all in the last 20min. Hope this works for you too.

0

It saves your bookmarks in a special Folder in your Google Docs account. So anytime a single change is made, it is saved..."in the cloud" :D

3
  • Is this true? I've looked for a folder and don't see it.
    – CoryR
    Apr 15, 2011 at 14:25
  • 1
    Even if this is how it works, it doesn't answer the question which is how to force it.
    – Chenmunka
    Oct 5, 2015 at 12:31
  • It's supposed to be called Google Bookmarks, but I did not find that in my account
    – zeta
    Apr 1, 2018 at 2:43
0

In case if it is not syncing with mobile device, uninstall the app (or app updates) and sign into Chrome again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.