0

6 months ago I bought a Logitech M220 Silent Mouse (wireless), it was all good until few days ago. The mouse stopped working suddenly, so I removed the battery and put it back but the mouse still did not work. I thought the aa battery was low, so I switched it with a new one. The mouse worked again but after few minutes it stopped again. I put it back the previous battery and it worked again.This is really strange because when the mouse stop, if I remove and then put back the same battery, it does't work, but it I put another battery it works...it seems like the mouse recognize the different battery (even if the brand of the 2 batteries is the same). I also tried with different brand batteries but the mouse keep stopping after few minutes (sometimes it work for 2 minutes, other times for 20 seconds).

I also tried this: when the mouse stopped I keep moving the mouse and after 15-30 secs it started working again (without removing the battery).

This is a strange behaviour and really annoying, I cannot understand what is going on.

Finally I tried to change usb port but the problem still remained.

I use this mouse on a notebook, that is connected via ethernet, and I have no other devices around me that can interfere with the mouse.

Somebody know a possible solution?

Thanks

2 Answers 2

2

I have experienced this type of problem before and my issue was related to an increase in wifi traffic in the area. Try to move away from your wifi router and try again or if your device is a laptop, take your laptop and your mouse to your local Starbucks and try it there. if the problem goes away, then you have wifi interference in the Area where you work. Move your stuff further away from that spot.

3
  • Thanks for the reply, but my router is very far from my room, so far that the wifi signal does not arrive here. This is why I use a ethernet connection (tp-link powerline).
    – sound wave
    Feb 14, 2018 at 13:32
  • @soundwave Could there be another source of interference? Neighbor's Wifi etc... on 2.4GHz? You should really go out of your environment and try.
    – pythonian
    Feb 14, 2018 at 16:57
  • Thank you! I've been trying to use my new Logitech MK295 keyboard-mouse combo with my Raspberry Pi 5 and couldn't get it to work. I installed Solaar and saw that both keyboard and mouse lost connection to the receiver almost all the time. I thought I had to return them and search for another model. Your comment saved me the trouble! I moved my wifi router away from my desktop and it fixed the issue! Thanks again! :)
    – nitsas
    Jan 21 at 8:57
0

When the mouse stopped, I kept moving the mouse and after 15-30 seconds and it started working again (without removing the battery).

So it doesn't sound like a battery issue.

This strange behaviour is really annoying and I don't understand what is going on.

As an honest opinion, it sounds as if your mouse is bad. But given the options, it's hard to know for certain.

My first thought is that the M220 is incorrectly putting itself to sleep (which is normally done to conserve battery life). That said, another possibility is you're bumping the On/Off button on the bottom of the mouse (and perhaps that switch has become faulty).

As for other reasons your issue could be occuring, I think they would all be likely related to your computer:

  • It might slow or freezing up temporarily.

  • It could be disabling the mouse itself to conserve power or otherwise may be trying to go to sleep because it thinks you're not using it.

  • It could be losing the connection itself due to driver issues or perhaps a (real or perceived) weak connection.

You will probably want to consider all of these and narrow them down before deciding whether to replace your mouse or not. As general guidelines, I would make sure I had the latest drivers (both from Logitech and for my other PC hardware), check the power settings for the PC, watch for a general lack of responsiveness and pay attention to any errors before making a decision.

2
  • thanks for reply - I did this superuser.com/questions/53740/… but did not work - I've just checked the On/Off button and it works properly - I'm going to buy new batteries
    – sound wave
    Feb 13, 2018 at 12:47
  • You're welcome. I hope you get your issue fixed. Feb 13, 2018 at 12:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .