0

I'm having an issue running a file ecl.e it's a 32-bit program.

I get the following if I run with bash:

bash /home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e
/home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e: /home/user/miniconda2
/envs/iraf27/iraf//bin.linux/ecl.e: cannot execute binary file

and,

./home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e
-bash: ./home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e: No such file or directory

I'm running the program on x86_64. So I understand there would be in issue with not having the right libraries. I looked to fix this by getting the libraries:

apt-get update
sudo apt-get install libc6:i386 libz1:i386 libncurses5:i386 
libbz2-1.0:i386 libuuid1:i386 libxcb1:i386 libxmu6:i386

However the problem still persists.

This is the output if I run file on it:

file /home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e: ELF 32-bit LSB executable, 
Intel 80386, version 1 (SYSV), dynamically linked, 
interpreter /lib/ld-linux.so.2, for GNU/Linux 2.6.9, not stripped

and ldd:

ldd /home/user/miniconda2/envs/iraf27/iraf//bin.linux/ecl.e
not a dynamic executable
0

This error usually means that the kernel does handle the executable format. This happens f.e. if you use the Windows On Linux subsystem of Windows 10, which runs only 64-bit executables. If you update Ubuntu to 18.04 or 18.10, you can install a 64 bit version natively via sudo apt install iraf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.