4

I have an Electron app that has registered a custom url. I checked the box "remember my decision" when I was prompted to open the external application while using Chrome (mac osx).

I now need to have that dialog re-appear.
How would I un-register this url handling?

I've tried deleting the item in the plist as hinted here:

Deleting the line in the plist seems to just regenerate when I launch the app again. I've also attempted changing the version of the app, but that didn't help either.

Has anyone had any luck re-engaging the dialog that asks the user "remember my preference" when opening a custom url handler?

2
  • Dammit, did they break RCDefaultApp? That gives me yet one more reason to stay on El Cap :/
    – Tetsujin
    Feb 13 '18 at 18:36
  • Aye, I agree. I really just need to do this for testing, seems some users don't push the "remember" checkbox and are experiencing some issues. I need to do this to repeat their scenario.
    – Chris Weed
    Feb 14 '18 at 20:44
0
  • Quit chrome

  • Open "~/Library/Application Support/Google/Chrome/Default/Preferences"

  • Search for the "protocol_handler" entry

  • Find the offending app/url. i.e.

      "https://miro.com":{"miroapp":true}
    
  • change to

      "https://miro.com":{"miroapp":false}
    

(Guessing you could also remove)

  • open chrome again and test.

Working in Chrome 87.0.4280.88

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.