10

My Windows 10 Professional (version 1709, build 16299.214) has repeatedly restarted itself in the past in order to install updates. I've set group policies to prevent this, however the system seems to ignore these.

Last night it has happened again and the Event Viewer has recorded the following message:

The process c:\windows\system32\svchost.exe (COMPUTER) has initiated the restart of computer COMPUTER on behalf of user NT AUTHORITY\SYSTEM for the following reason: Operating System: Service pack (Planned) Reason Code: 0x80020010 Shutdown Type: restart

My group policy settings under Computer Configuration > Administrative Templates > Windows Components > Windows Update are as follows:

— Configure Automatic Updates: Enabled, Configure automatic updating: 2 - Notify for download and auto install

— No auto-restart with logged on users for scheduled automatic updates installations: Enabled

All other group policy settings in this section are set to Not configured.

I had not logged off for the night as I never do that. What am I doing wrong?

  • 1
    Can you check to what the following regkey is set? HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoRebootWithLoggedOnUsers – architekt Feb 14 '18 at 10:35
  • Thanks. NoAutoRebootWithLoggedOnUsers is set to 1. – Bonilla Feb 14 '18 at 11:17
  • The whole section looks as follows: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU] "NoAutoRebootWithLoggedOnUsers"=dword:00000001 "NoAutoUpdate"=dword:00000000 "AUOptions"=dword:00000002 "ScheduledInstallDay"=dword:00000000 "ScheduledInstallTime"=dword:00000003 – Bonilla Feb 14 '18 at 13:20
  • is HKLM\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU\NoAutoUpdate set to 1 too? – architekt Feb 14 '18 at 13:21
  • NoAutoUpdate is set to 0 – Bonilla Feb 14 '18 at 13:37
9

You must have 4-Auto download and schedule the install enabled in Computer Configuration\Administrative Templates\Windows Components\Windows update\Configure Automatic Updates policy to have No auto-restart with logged on users for scheduled automatic updates installations option working.

See this table:

enter image description here

Read more detailed here, in Delay automatic reboot chapter:

Manage device restarts after updates

7

Windows 10 does what it wants, not what you want.

Windows 10 will change any settings at any time by itself when updates install.

Windows 10 will disable drivers and devices considered incompatible with it, even if they previously worked.

That said, on Win 10 Pro if you really want to disable updates, make sure the update service is permanently disabled.

Additionally, disable it's permissions to restart.

With those 2 properly set, you should be fine.

In the case of wireless connections, you can 'cheat' by enabling Metered connection. That will prevent auto-downloading of updates.

  • 2
    I wouldn't consider "windows 10 just does what it wants" to be a viable solution/answer. We run Win 10 Pro and Enterprise on several hundred computers with windows updates disabled (updates get handled via altiris by symantec) and we haven't got these problems. – architekt Feb 14 '18 at 12:47
  • Anti-virus controlling everything is an entirely different scenario. I use Kaspersky too to control updates and firewall rules. – Overmind Feb 14 '18 at 13:00
  • 2
    Altiris is not an AV-Software. It's pretty much like SCCM. But that doesn't matter, the fact that windows update itself is disabled (and stays disabled) is whats important and clearly contradicts your answer – architekt Feb 14 '18 at 13:15
  • Thanks for your suggestion! I actually want to do the updates, especially the security related ones. I just want to do them when I feel like it and not when Windows feels like it. :) – Bonilla Feb 14 '18 at 13:25
  • @ Martin Fischer the point is to have something controlling things, no matter what it is (AV or other). Uncontrolled updates start to make things unusable way too often today. Just look at the one denying all outlook attachments as a relatively recent example. – Overmind Feb 15 '18 at 8:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.