I'm trying to use Virtualbox's shared folder functionality, and I can't get the automount folder feature to work.

I've followed directions in various SO/AskUbuntu questions, and it seems like I set up shared folders correctly.

More details:

Mounting the folder with sudo mount -t vboxsf vbox_shared /media/vbox_shared works, including write access.

I've installed Virtualbox Guest Additions, and lsmod | grep vboxguest returns vboxguest 294912 2 vboxsf,vboxvideo.

I've run sudo usermod -G vboxsf -a <username> to add myself to the group.

I've restarted the virtual machine.

In Virtualbox settings, I've set Folder Path: C:\Users\<myusername>\vbox_shared, Folder Name: vbox_shared, Auto-mount and Make Permanent are checked.

Host is Windows 7 Enterprise, Guest is Ubuntu Server 17.10, Virtualbox 5.2.6.

What else could be the cause of this?

1 Answer 1


Automount performed by appropriate systemd unit service:

  • virtualbox-guest-utils.service - if you have installed virtualbox-guest-dkms and virtualbox-guest-utils


  • vboxadd-service.service - if you have installed VBoxLinuxAdditions.run from VirtualBox virtual CD.

In the both of the cases appropriate service possible failure to start caused by unit dependecies.

Possible solution:

sudo systemctl edit --full vboxadd-service


sudo systemctl edit --full virtualbox-guest-utils

and remove "systemd-timesync.service" from "Conflicts=" line in [Unit] section. Then reboot.

UPDATED If you'll update Virtual Guest Additions you'll possible have to change manually version number in the vboxadd-service. See also selectstriker2 comment below.

  • 1
    So I ran into an issue when updating from 5.2.18 to 5.2.22 which caused the vboxadd-service configuration to not update from .18 to .22. This caused vboxadd-service to fail to start. I fixed those lines in the file using this method and was able to get the vboxadd-service to actually start Dec 7, 2018 at 23:06
  • Changing the version number worked for me. Thanks.
    – Jin Kwon
    Dec 14, 2019 at 11:36
  • Updating the version from 6.1.26 to 7.0.10 (the new extension pack) worked for me. Oct 17, 2023 at 16:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .