4

I'm trying to install Lubuntu 17.10 as a guest OS on a virtual machine. I'm using VirtualBox Version 5.2.6 r120293 (Qt5.6.1) and my host OS is CentOS 7.

I create a virtual machine, loaded the ISO image of Lubuntu 17.10 into it and started the machine. I got the options where it asked whether I wanted to try Lubuntu or I wanted to install. I selected install and the only thing I ended up getting was a garbled screen.

So, I booted it again but this time I selected try Lubuntu. But the result was the same. Following is a screenshot of the same.

garbled screen

I'm not sure what is the issue. Is it a problem with the OS or VirtualBox? And how can I resolve it?

2

Not sure if this will work in your case, but my guest Lubuntu 17.10 looked exactly the same when running on a windows host. Here's what fixed it for me

1. disabling nested paging (system → acceleration → enable nested paging checkbox)

2. increasing the video memory to 128 mb (display → video memory slider)

2
  • Increasing video memory alone was enough for me. (I only had problems when going full screen though). – Zitrax Oct 23 '18 at 7:47
  • 3. Possible alternative to increasing the video memory: Make sure the Monitor Count is 1. – nobar Oct 24 '18 at 20:08
2

I had the same problem, using Virtualbox 5.1.38_Ubuntu r122592 on Mint 18.3 as Host and Mint 19 as Guest both 64bit with Cinnamon.

The only thing that worked for me was to boot the guest in compatibility mode (during boot, there is a window prompting "starting Linux Mint in 10 seconds". If you hit "Enter" at this point, a menu appears, making it possible to switch to compatibility mode). This forces Mint to use Software rendering.

In Virtualbox I tried both enabling and disabling 3D-acceleration, increasing grafic memory, disabling nested paging, switching to full screen and back. None of this had an effect on the problem for me.

I wanted to share this, because, maybe it is helpful for someone in the future.

1
  • Thanks for this. Looks like that, after installing the VirtualBox guest additions, you can use Mint normally. – Chris Browet Nov 2 '18 at 8:59
0

Same problem on lubuntu-18.04 + VirtualBox 5.2.34. Turning off nested paging and increasing video memory didn't work. The solution was to press F6 on the boot menu (before starting the installation) and select nomodeset.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.