2

It appears that all of my USB 3.0 ports have stopped working. Yesterday, my mouse has randomly stopped working during use. When I unplugged and re-plugged it, my keyboard has stopped working as well. After attempting different solutions, it appears that they only work when I connect them to the USB 2.0 ports. When trying to connect any device to the USB 3.0 ports, they don't seem to work. I have about 8 USB 3.0 ports a not a single one of them works. I have a webcam which has lights on it, and when I connect it to the 3.0 ports, the lights light up, suggesting there is power going through the port, however the webcam isn't detected at all. My keyboard, mouse and microphone should also light up when connected, however these only light up and work when connected to the 2.0 ports. I've tried checking the device manager, and uninstalling all of the devices under Universal Serial Bus Controllers tab, and restarting, this did not fix the issue.

I've noticed I had three devices under the 'Other devices' tab. These were:

  • Universal Serial Bus (USB) Controller
  • Universal Serial Bus (USB) Controller
  • SM Bus Controller

I have installed the Intel USB 3.0 drivers and one of the Universal Serial Bus (USB) Controllers disappeared from the tab. I've also installed the Intel Chipset installation and the SM USB Controller disappeared from the tab as well. Now I only have one Universal Serial Bus (USB) Controller in the 'Other devices' tab, and searching for updates doesn't seem to help. I've also tried manually selecting the Intel USB 3.0 driver for it, but it doesn't seem to apply to it. Keyboard doesn't work if connected to 3.0 port during boot, so can't go to safe mode or bios unless keyboard is connected to 2.0, or if I'm using a PS2 keyboard.

Please help, thank you.

I've tried running a Microsoft Easy Fix diagnostic which has also located the USB Controller with a missing driver, yet hasn't detected any drivers for it. Any idea whether this could be the problem, and where to find drivers for it? I've already tried installing a couple, listed below.

XHCI hand off and EHCI hand off are both enabled. USB legacy support is enabled.

Drivers I've reinstalled

  • Intel(R)_USB_3.0_eXtensible_Host_Controller_Driver_5.0.4.43
  • Chipset_10.1.1.42_Public

Motherboard - MSI MS 7916 (Z97 GAMING 7)

OS - Windows 7 Ultimate 64Bit

Processor - Intel Core i7-4790K

  • I always understood that XHCI hand-off and EHCI hand-off shouldn't be enabled at the same time. Can you try with ECHI hand-off disabled? Then, remove the driver for the USB controllers and also check the checkbox to actually remove the driver package. Reboot and reinstall the Intel drivers again. – AdmiralFreebee Feb 15 '18 at 12:41
  • I've tried this just now. After removing and reinstalling the drivers, the USB 2.0 ports seemed to stop working once Windows was booted, and the 3.0 weren't fixed. Had to restore system to an older date. – Jashani Feb 16 '18 at 10:41
0

The MSI Z97 GAMING 7 mainboard has three different USB 3.0 controllers, one embedded Intel, and two AsMedia chips. The board is about 4 years old, and USB 3.0 in that time frame might have some "anomalies" that might require special treatment. I would strongly suggest to go to the original manufacturer (MSI) and download all drivers from their website.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.