0

I have looked for an answer to this question on Linux Questions, https://www.linuxquestions.org/question ... 175622990/ but the person helping me was unable to resolve the issue. I have also asked on the Linux Mint forum, in case my issue was distro-specific, but have received no answer. I am trying to access the localhost, located on my laptop, from my iPhone. The laptop is running Mint. I have successfully accessed the localhost running on my Debian desktop, which is connected via ethernet, but when I try to access the laptop, which is wireless, the phone cannot connect. In the URL bar in Safari, I type in http://192.168.0.9, which is the address that comes up under inet addr in ifconfig. I have completely disabled apparmor, and I have confirmed that the firewall is off in the GUI application, and off when I run ufw status. If you visit the URL I provided for the discussion I have had on Linux Questions, you can see the apache2.conf file and my logs. The person who was helping me has verified that all appears to be correct. The configuration appears to be identical to the desktop settings. I have confirmed that the correct port is open and apache is listening on it. I am able to ping the laptop from another computer without any packet loss. I have checked the Netgear router settings, and there doesn't appear to be anything blocking it there. I have not been able to find evidence of the pings or the attempted access in logs.

What am I missing? Is there another setting on the machine that could be blocking my phone?

1

Most likely situation is that your wireless network has device isolation enabled.

This means that 2 devices connected to the wifi can not not talk to each other.

| improve this answer | |
  • I did have a look at the router settings and I couldn't see anything. I have seen a comment before about wireless isolation being an issue, but I wasn't sure if this router supported it. Is the wireless isolation setting the one I would be looking for? – user873176 Feb 15 '18 at 23:06
  • From the machine serving the connection, what do you get when you ping 127.0.0.1? – Tim_Stewart Feb 16 '18 at 16:52
  • @Dylan_Oscar it may be called something like "device isolation", if you update the question with your wireless access point/router model then maybe somebody can tell you if the setting exists. I know an early router I had the option was not exposed in the GUI and had to be changed with the terminal – hardillb Feb 16 '18 at 21:19
  • The router is Netgear D7000. I have to get the password off my housemate to access the settings. I'll do that soon. – user873176 Feb 16 '18 at 21:30
  • @Tim_Stewart Pinging 127.0.0.1 I get 0% packet loss. – user873176 Feb 16 '18 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy