Ubuntu 16.04x64

Synergy 1.8.8


macOS 10.13.3

Synergy 1.8.8

I would like to have the media keys on my keyboard sent to the server regardless of what screen I am on.

On the client, I could not find any configuration that needed to be made to activate this.

On the server, I went to Configure Server then clicked on the Hotkeys tab. I added a new hotkey for the keystroke(AudioMute). I then selected that hotkey and added a new action for it. In the configure action I have chosen the following:

Choose the action to perform

Press and release a hotkey

only on these screens

server screen selected

This action is performed when

the hotkey is pressed

From my understanding, this should make it so that when I press the Mute media key that it should route back to the server and execute the Mute media key. However, this does not seem to be working at all. When I press the key associated with the hotkey on the server it will mute the server. When I press the hotkey on the client machine it will mute the client.

I have tried using a modifier with the media key such as ctrl+AudioMute. This did not work either. Am I missing a setting or configuration? It seems like the hotkeys may be overridden by the default actions on the client machine. I am unsure of how to further troubleshoot as I am not as familiar with macOS.


Synergy 1.10 added this feature with the addition of the target screen for the keystroke() action.

 keystroke(key) = keystroke(key[,screens])

Currently it builds the options at service startup in sequential order, so if you're going to use a destination screen make sure the keystroke setting appears after the screen definition in the configuration.

 keystroke(AudioMute) = keystroke(AudioMute, myUbuntuServer)
 keystroke(AudioPlay) = keystroke(AudioPlay, myUbuntuServer)

You can set almost any key combination if you'd prefer to use CTRL+AudioMute for the server and mute to operate normally on the client:

 keystroke(control+AudioMute) = keystroke(AudioMute, myUbuntuServer)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.