0

I am having trouble with some captions in MS Word. I'll describe the situation. For reference, I am using Word 2010.

I have a large (100+ pages) document that has many figures and tables in it. I would like to include a LoF and LoT in the front matter of the document. Please note, right away, that using something besides MS Word is not an option (no matter how much I wish it otherwise).

In this document I have set up two custom List Styles.

The first list style makes use of MS Words built in headings 1-5 and are numbered headings (e.g. Section 1, Section 2). The second list style makes use of MS Words built in headings 6-9 and begin with unnumbered appendix sections, e.g. Level 1 of the second list style is Appendix A. The next subsection would be A.1, then A.1.1, and so on.

Now, when I use the Add Caption feature in MS Word, it brings up a dialog box where I select the heading level for the table or figure. For captions in the main body of the document (i.e. in the numbered sections) I want them to be Table 3-1, Figure 4-1, etc. so for that dialog box I select "Heading Level 1".

But that means when I add captions to my figures and tables in the appendices it labels them Table 6-1, Table 6-23, etc. because it is built starting with Heading 6 (because I already used headings 1-5 in the first list style). I've tried manually changing the field code for the caption which does work but only temporarily. Every time I add a new caption anywhere in the document MS Word reinforces those settings for all captions.

Does anyone have any suggestions for how to resolve this situation? To get captions to match the section they are in, instead of setting them categorically in a single dialog box?

Is it clear what I am describing?

1

Rather than using the Insert Caption dialog to insert your captions, instead just copy and paste an existing one. Then select the new caption paragraph and press F9 to update (ie so the numbering updates).

So it correctly displays either section number or appendix letter, you need to change the field code so it looks for the right "Heading level". To view the field codes for the caption, select it and press SHIFT F9 keys. You'll see that the STYLEREF FIELD refers to 1 (if your caption was inserted and Heading 1 selected) or 6 (if your caption was inserted and Heading 6 was selected). Likewise at the end of the SEQ field, you'll see either a 6 or 1.

Just manually edit that number in both fields so that it is "6" if your caption is in an Appendix; if it is in a main section, just make sure both fields have a "1" and not a "6".

| improve this answer | |
  • I will give that a shot. I hope it works. A surprisingly simple solution if so, makes me feel silly for not thinking of it! Also - will have to make sure "auto update" fields on file opening/saving is not checked. – Nukesub Feb 20 '18 at 2:38
  • I think you'd be OK with auto update on, as it seemed to be inserting via the Insert Caption dialog that was triggering the change of all captions to either Heading 1 or Heading 6. – Tanya Feb 20 '18 at 3:44
  • I have so many figures and tables, I'm not sure I want to risk it! But thank you for helping me resolve my primary issue! – Nukesub Feb 20 '18 at 4:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.