4

I have an HP Elitebook 8570W laptop.

I get lots and lots of typos because the keyboard "thinks" I accidentally hit two keys. nonononono! I just type very fast.

Is there any way to change the debounce time of this keyboard?

4
  • Those settings are generally related to OS, so please post your operating system too. Also, what are the typos, why do you think you type too fast? Feb 18, 2018 at 16:30
  • @MátéJuhász, the typos are any double key such as "aa", "oo" etcetera and any two keys hit in rapid sucession (using ten fingers). And I don't think I type too fast, I know it. Ever used a real IBM101 keyboard? That lets you type really fast! Feb 27, 2018 at 9:13
  • are you talking about double clicks? I have noticed double clicks that i don't make, and i hope your answer will help. Feb 4, 2020 at 12:14
  • @AlexanderMyravjev, I believe the hardware/software considers any two keystrokes that fall within the bounce time as a typing error and only considers the first keystroke, ignoring the second. Formally, though, the debounce time has to do that an electrical/mechanical contact can have "sparks" when pressed that would be seen as multiple keystrokes but that should be ignored. Feb 4, 2020 at 14:20

1 Answer 1

6

I found an article on hp which says to decrease the keyboard debounce time in the registry, however on my Windows 7 this time was zero. Maybe this zero says "use default" or maybe this zero means the debounce is done by the hardware.

Anyway, I changed it to 35 ms and later to 20 ms and it seems to have worked as I have much less typos than before. The registry key is:

HKEY_CURRENT_USER\Control Panel\Accessibility\Keyboard Response\BounceTime

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .