I´ve had this problem for a while now:

A few days after a reboot, the audio gets choppy whenever something is going on at the network, regardless of if the audio is streaming or locally stored. The problem gets worse and worse till I reboot the computer, and again it happens after a few days. The audio is the onboard realtek chip, but this also happens if using USB headphones.

This is what I´ve tried:

  • bought a new network card (and disabled the old one which was on the motherboard)
  • tried all possible settings for various sample rates in the windows audio settings
  • cloned the system onto another harddrive and booted from that instead
  • installed ASIO4All, which allowed me to make very large buffer sizes, but obviously this only works with applications such as winamp that support Asio4All, so no luck with spotify or chrome.
  • disabled all 3rd party services I could find which didn´t seem to be needed.
  • used latencychecker to see what could be an eventual driver issue. It reported USBPORT.SYS, which is using the same driver for years - much longer than the problem has been going on for.
  • defragmented system partition and the one holding the hiberfile with defraggler.

In fact the problem is now showing up after just half a day...

The motherboard is an ASUS P8h-77V-LE with 16 GB RAM and a 3770k CPU.

  • when you say "spotify or chrome," this means to me that you are listening to audio from network sources. Does this choppiness happen with listening to audio that is stored locally on the computer? If not then this is probably going to be a network bandwidth or connectivity issue that has nothing to do with the audio subsystem.
    – Yorik
    Feb 23, 2018 at 18:34
  • 1
    @Yorik, This happens with locally stored music as well unless, as mentioned, that I route the audio through asio4all with very large buffer settings. This unfortunately is not something that can be done with chrome and spotify. It´s something I´m doing in winamp. But even if it could be applied to all applications, I don´t think it´d be a good workaround : I get the feeling that things do slow down in general the longer my current windows session, so I want to to find the exact culprit.
    – Corey Hart
    Feb 24, 2018 at 11:36
  • @Yorik, I´ve added to the description now that this is also for local audio.
    – Corey Hart
    Feb 24, 2018 at 11:39


You must log in to answer this question.

Browse other questions tagged .