1

I have a pFsense machine running as my main router. A switch is connected to the ethernet out of the machine which connects to multiple devices. All those devices receive their IPv4 and IPv6 address from the router. I also own 2 Asus AC66U's which are both configured in the AP (Access Point) mode. They act as a switch and send out both 2.4 and 5 GHz WiFi. I also have a homeserver that is connected wired to the switch, which also has an IPv4 and an IPv6 address (static).

My network is working fine without problems, I can reach both IPv4 and IPv6 addresses, and alls local devices are accessible via their local IP address. My real problem however is when I have a client connected using WiFi on any of those two AP's, I cannot reach the server over IPv6. The ND (Neighbour Discovery) is failing only when connected over WiFi and only when connecting to that specific machine (homeserver, running Ubuntu 16.10). I've tried multiple version of Ubuntu, multiple NIC configurations etc., none seem to be working.

The weird thing is, when I reboot my device that is wirelessly connected I can ping the server over it's IPv6 address. But after a short while, the Neighbour Discovery starts failing and I can no longer reach that server as long as I do not reach it over it's IPv4 address. As soon as I ping or ssh with the servers' IPv4 address, the ND is working again, but only for a short while, and it eventually repeats.

I've been doing some research and I can see the server is receiving NS (Neighbour Solicitation) from the wirelessly connected device and is sending back a NA (Neighbour Advertisement). When I use tcpdump on the AP, I can see the NS, but the NA does not arrive. I have no idea wether this is at fault at at the AP or at the server. It's also strange that it's working fine when I'm connected via wire.

I'm running the latest Merlin Firmware and have tried multiple versions. I made multiple bug reports and forum threads on both the official Asus forum as the Forum where the custom firmware for Merlin is discussed and no one seems to be able to help me nor do I get replies. So this is a last resort to fix this issue, as it's very annoying.

I can give more information when needed, and am willing to change one of the AP to other firmwares etc. I think I need to look into the AP's as it's the only thing that actually makes the difference between wireless and wired and the NA does not arrive there.

  • I enabled forwarding on the bridge and the pinging started working immediately. Not sure if this is related or just because the interface somehow reset when setting this value? But this was only the host itself, the guests are still showing this problem. Do I need to enable forwarding on the hosts as well? – Qlii256 Feb 19 '18 at 17:54
  • How is your networking actually configured? It's very difficult to follow in prose. Demonstrate by showing your existing configurations. – Michael Hampton Feb 19 '18 at 18:11
  • Ok, I've just realised that my 2nd nic, which is not configured as a bridge suffers from the same issue eventually. Suddenly it will not pass the NA to the clients. I can still see the forwarding of the NA on the server, but my router nor my client sees this NA. I have 2 NICs, but that's just for testing purposes. It's connected directly to my router and I'm using static IP address for both IPv4 and IPv6. – Qlii256 Feb 19 '18 at 18:17
  • Ome more thing why I thought it was both of my access points is because it does work while connected via wire. This problem only happens over WiFi. So, this actually rules out the bridge being at fault. My ap's are Linux based. AC66U – Qlii256 Feb 19 '18 at 18:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.