0

I have this excerpt from one of my Dockerfile[s]. Any attempt to install a software silently would fail. In another Dockerfile, I already had tried with oracle-xe without success. Here in this docker file, I also tried Git for Windows, OpenSSH, and gpg4win, none of them would work returning a very long return code.

FROM microsoft/nanoserver
ADD assets/jdk-8u161-windows-x64.exe C:\\temp\\install
RUN powershell.exe -Command Start-Process C:\temp\install\jdk-8u161-windows-
x64.exe -ArgumentList '/s' -Wait
# Or
# C:\temp\install\jdk-8u161-windows-x64.exe /s

Can you help me solve this please?

  • Does the JDK install without the silent flag? What is the exit code? – Unfundednut Feb 20 '18 at 14:56
  • Yes, on the host it installs without a problem, as do all other failing software. – Herve Mutombo Feb 20 '18 at 14:58

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.