I'm using pass as my main password manager(which uses gpg2), but since a few days i can't create new keys, I always get the error message:

There is no assurance this key belongs to the named user
[stdin]: encryption failed: Unusable public key

I already set the the trust of my key to ultimate als suggested here

And also checked that my key is not expired. Any suggestions how to fix this or should i get a new key?

  • I voted to migrate your question to Super User. I think it might be a better fit there.
    – Tobi Nary
    Feb 21, 2018 at 15:22
  • This is better asked on the pass mailing list.
    – mricon
    Feb 21, 2018 at 16:24

3 Answers 3


From https://stackoverflow.com/questions/33361068/gnupg-there-is-no-assurance-this-key-belongs-to-the-named-user:

do gpg --edit-key <KEY_ID> and gpg>trust

If you're sure about the authenticity of your key, select the trust level 5.

  • As i mentioned in my question i already tried this and it didn't resolve my issue. I solved it running pass init again on the directory with my gpg-key May 25, 2018 at 11:13

I had simillar issue. In my case I generated the GPG key for RSA (sign only).

It can be fixed either by regenerating it for RSA and RSA (default) of by adding a subkey for RSA (encrypt only).

The second option can be done by gpg --edit-key <KEY_ID> and gpg> addkey and select RSA (encrypt only)


Solved the problem by running:pass init <gpg-id> which reencrypted the existing keys. Afterwards i was able to decrypt my keys again normaly

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.