37

lt is really strange that when l try to use git push today,error reports Fatal: HttpRequestException encountered and requires me to enter username and password.

l have tried git pull and git clone and they both work well.

And it works well before this day and regenerating ssh key seems to be useless.

Can anyone help me with that? Thanks in advance!

2

4 Answers 4

47

Are you using Windows and GitHub? This is because GitHub disabled weak encryption, specifically TLS v1.0 and v1.1

Using the Git Credential Manager for Windows will fix this. You can download the latest version.

2
  • Yes! l will try it
    – Rosmee
    Feb 23, 2018 at 8:53
  • I am having a similar issue, but this does not fix it. I already have the lattest version installed. :(
    – Aaron C
    Apr 5, 2018 at 17:24
7

Felipe's answer is correct. Just wanted to mention that updating Git for Windows also works.

It updates Git Credential Manager, Git itself and all other bundled software at the same go.

(Not enough reputation to comment so had to add this as an answer instead.)

2

You can download and reinstall the latest source release of Git from https://git-scm.com/
I am using windows and it worked for me.

1

I had the same issue. If you are using 2FA, you need to use your access token instead of a password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.