3

I'm frequently in the position where I work from home and use the companies VPN to access internal services, which is why I also use the internal DNS server. Everything works fine and without great delays there.

My problem is that Firefox takes 10-15 seconds for DNS resolution for some domains. I've tried to pinpoint the issue and it does seem like the resolution issue is limited to the browser.

Firefox does not use any proxy. If I access kernel.org on Firefox, the DNS resolution time is somewhere between 10-15 seconds. If I then flush the DNS cache and time the DNS resolution with nslookup (power shell), it takes about 0.2 seconds. The answer comes from the companies internal server as expected.

DNS Resolution kernel.org Firefox vs nslookup

If I disconnect from the VPN, DNS resolution times are back to normal. Internal domains and some external domains (e.g. google.com) don't have any DNS resolution delay via the VPN. I'm quite lost as of why this occurs.

What could be the reason for this immense delay?


edit: According to this question "VPNs are broken on Windows 10" or there are issues with IPv6.

I can not disable IPv6. I should have also mentioned that we use OpenVPN for the VPN.

0

Apparently this has been an issue for 10+ years with Firefox.

I was able to mitigate the problem by disabling IPv6 DNS in Firefox with the following setting in about:config:

network.dns.disableIPv6;true

This is only temporarily viable for me, as currently all internal services still offer legacy IP support.

I've marked this as solved, as it seems to be a temporary workaround, with no other solution in sight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.