1

I want to disable permanently my touchpad when my Debian-based Linux boots up. Every time it boots up, I disable it with xinput —disable #. # Being the ID of the touchpad in xinput command. I disable the touchpad on my laptops because it seems no matter how much tweaking I do they always suck. Jittery and not accurate. Easier (and prefer) to just use a mouse.

Please help me to resolve it permanently. Thank you.

desktop@local:~$ xinput 
⎡ Virtual core pointer                      id=2  [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4  [slave  pointer  (2)]
⎜   ↳ Logitech M325                             id=10  [slave  pointer  (2)]
⎜   ↳ PixArt USB Optical Mouse                  id=11  [slave  pointer  (2)]
⎜   ↳ eGalax Inc. eGalaxTouch EXC7910-1023-12.00.00  id=13  [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                id=15  [slave  pointer  (2)]
  • In Control Centre, under Mouse options there is a tab for the touch-pad, which includes the option to enable. Disabling this should remove all functions. – AFH Feb 23 '18 at 16:54
1

You can force the X server to ignore it by writing your own xorg.conf file. Have a look at the InputClass section, keyword Ignore. See man xorg.conf for details.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.