2

I have a program on my Win10 machine that I run in WINXPSP3 compatibility mode. I set this up while logged in as admin using the "Change Settings for all users" dialog.

So when I run the program while still logged in as admin it pops up a UAC prompt (but doesn't ask for creds), so I click past and the program runs fine. I did not set "Run as Administrator"

Then I log off and I log back in under my normal-rights user, I run the program and it crashes on launch--no UAC prompt--the same error that made me go to compat-mode in the first place. So it clearly isn't even using compat mode, though I can look at the properties and see the greyed-out-checked box (because it's set for all users).

So, two key questions:

  1. Why would compat-mode require elevated rights in the first place?

  2. Why isn't the "...all users" setting working at all?

| improve this question | | | | |
5

Only windows 7 and up have separated administrative rights from user rights.

When you use Windows XP or earlier as compatibility mode, you need administrative rights because in those operating systems administrative rights were always present and as such, it is likely that the program requires administrative rights if you need that level of compatibility.

| improve this answer | | | | |
  • @Ramhound I agree with the edit. OSses look worse than Operating Systems. :) Thanks for the edit. – LPChip Feb 24 '18 at 14:59
  • operating systems doesn't have to be capitalized (determined by Wikipedia article), but OS is capitalized I assume because it's an abbreviation, I don't even know what the proper plural form of OS would be to be honest. – Ramhound Feb 24 '18 at 15:01
  • I always use OSes for the plural form just like that when I don't type in out fully and it make sense to me when I read it that way too en.wiktionary.org/wiki/OSes#English. This is probably a personal preference scenario of which you use but perhaps a question for English SE... LOL – Pimp Juice IT Feb 24 '18 at 20:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.