0

I use KMPlayer 3.6.0.87. I've never really had a problem with this version, but yesterday I downloaded one particular movie and for some reason the audio won't play (and this error only occurs with this specific video file). I tried to download the latest version of KMPlayer to see if that'd fix the issue, and what do you know, it did. The audio played just fine. The only problem is that I refuse to use the newer versions of KMPlayer as they are so full of glitches I wouldn't even know where to begin.

I was wondering if maybe there was a way to make the audio work on version 3.6.0.87. Maybe there's a setting I can change to fix things or something like that. I'm pretty much technologically illiterate, so I don't want to play around with the audio preferences and make things worse. So maybe someone here has a solution to the problem? I'd be forever grateful!

Here's some info on the movie file:

Format : Matroska
Format version : Version 4 / Version 2
File size : 3.80 GiB
Duration : 2h 9mn
Overall bit rate : 4 207 Kbps
Encoded date : UTC 2017-08-04 21:30:40
Writing application : mkvmerge v14.0.0 ('Flow') 64bit
Writing library : libebml v1.3.4 + libmatroska v1.4.5
DURATION : 02:09:16.757000000
NUMBER_OF_FRAMES : 387838
NUMBER_OF_BYTES : 255754858
_STATISTICS_WRITING_APP : mkvmerge v14.0.0 ('Flow') 64bit
_STATISTICS_WRITING_DATE_UTC : 2017-08-04 21:30:40
_STATISTICS_TAGS : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
Video #1
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High 10@L5.1
Format settings, CABAC : Yes
Format settings, ReFrames : 16 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 9mn
Width : 1 920 pixels
Height : 1 036 pixels
Display aspect ratio : 1.85:1
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 10 bits
Scan type : Progressive
Title : @BD
Writing library : x264 core 148 r2762+56 7979737 t_mod_Custom [10-bit@all X86_64]
Encoding settings : cabac=1 / ref=16 / deblock=1:-1:-1 / analyse=0x3:0x113 / me=umh / subme=10 / psy=1 / fade_compensate=0.00 / psy_rd=0.80:0.10 / mixed_ref=1 / me_range=32 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=0 / chroma_qp_offset=-3 / threads=12 / lookahead_threads=3 / sliced_threads=0 / nr=0 / decimate=0 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=16 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=24 / scenecut=40 / intra_refresh=0 / rc_lookahead=48 / rc=crf / mbtree=1 / crf=15.0000 / qcomp=0.70 / qpmin=0:0:0 / qpmax=81:81:81 / qpstep=4 / ip_ratio=1.40 / aq=3:0.90 / aq-sensitivity=10.00 / aq-factor=1.00:1.00:1.00 / aq2=0 / aq3=0
Language : Japanese
Default : Yes
Forced : Yes
DURATION : 02:09:16.708000000
NUMBER_OF_FRAMES : 185975
NUMBER_OF_BYTES : 3820539091
_STATISTICS_WRITING_APP : mkvmerge v14.0.0 ('Flow') 64bit
_STATISTICS_WRITING_DATE_UTC : 2017-08-04 21:30:40
_STATISTICS_TAGS : BPS DURATION NUMBER_OF_FRAMES NUMBER_OF_BYTES
Matrix coefficients : BT.709
Audio #2
ID : 2
Format : Opus
Codec ID : A_OPUS
Duration : 2h 9mn
Channel(s) : 6 channels
Channel positions : Front: L C R, Rear: L R, LFE
Sampling rate : 48.0 KHz
Compression mode : Lossy
Title : @BD
Language : Japanese
Default : Yes
Forced : Yes

P.S.: I know I could just download another media player like VLC or mpv and solve this quickly, but I honestly like KMP's interface too much and I'm so used to it that I'd rather not watch the movie than download another player.

  • KMPlayer uses internal codecs and supposedly cannot use those installed system wide. As such, user are completely dependent on the app updates giving support for the specific formats they need. – user772515 Feb 26 '18 at 3:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.