6

Windows 10 and resizing partitions apparently don't mix. I needed to migrate a partition to a smaller SSD, as outlined in this post, so in an attempt to move my massive documents folder to a place where it will remain on the HDD, I tried to shrink my main partition, as it had 120 GB of free space. In the process, I defragged my HDD partition... more than is healthy.

Anyways, because Windows still wouldn't resize the partition, I tried resizing it with AOMEI partition assistant. I checked the disk twice- the program apparently used chkdsk to do so- and rebooted to apply fixes each time. After that, attempting to run the check would give me a frowny face of death (Stop code: CRITICAL PROCESS DIED, no underscores). I made the mistake of using that software to resize the disk. It ran in PreOS mode, and now my laptop won't boot. I see the Lenovo logo (it's a Lenovo laptop), then it goes away- and normally would be replaced by a Windows logo, iirc. I can access the ease of access center via keyboard shortcuts, but that doesn't have a link to the control panel as Win7 did. Ctrl+Alt+Del won't work- the shortcuts that do respond are limited to ease of access utilities and Win+P, which is useless.

I re-expanded the disk to the original size (plus 460KB or so) and ran chkdsk C: /f multiple times, as per recommendation of GParted. GParted says the NTFS is inconsistent, but everything else seems to point to it being functional- aside from it not being functional. I've also run whatever Boot/System Recovery thing is in the Advanced Repair Options, which immediately gives me an error saying it couldn't do anything.

So... can I fix this, or should I put it in my external enclosure and find some place to put my data? Also, if the booting is screwed, could I save my installed programs by copying some folders, perhaps Program Files/(x86) and .appdata?

If anyone knows how to correctly get Windows to resize a partition, that would also be useful for the future. Yes, I disabled hibernation/pagefile/other stuff, and consolidated free space with Defraggler.

I don't have a computer to set up USB tools with (I'm typing this from a Chromebook) but I do have a Ubuntu Live USB and a USB with Windows recovery tools (and a Win10 installer).

List vol output:

Volume 0 C Windows    NTFS  Partition 363 GB Healthy
Volume 1 D LENOVO     NTFS  Partition 24 GB  Healthy
Volume 2   SYSTEM_DRV FAT32 Partition 240 MB Healthy Hidden
Volume 3 E WINRE_DRV  NTFS  Partition 999 MB Healthy Hidden
Volume 4 F Storage    NTFS  Partition 19 GB  Healthy Hidden

If anyone knows how to make a properly spaced list, please tell me or suggest an edit!

8
  • And yes, I have done PLENTY of searching on Stack Exchange and elsewhere before posting. Nearly nothing I've found since starting the partitioning ordeal has been remotely useful. So please stop and think before marking it as a duplicate of a question that didn't help me at all.
    – jlc
    Feb 26, 2018 at 2:47
  • Unfortunately, resizing partitions is an inherently risky operation. If you happen to have a backup, you're best off restoring to it (if not, make a backup as soon as you get this working again!). If the partition is still generally readable when mounted elsewhere and only not bootable, you might have some luck doing an in-place upgrade of Windows to the same version via bootable drive — that should fix any corrupted OS files. But I'd recommend taking a backup before doing anything else, in case you cause further damage.
    – Bob
    Feb 26, 2018 at 2:54
  • Also, where did you run chkdsk from? Can you include a photo of where you end up after boot — are you seeing the ease of access center in Windows proper or just the recovery environment?
    – Bob
    Feb 26, 2018 at 2:55
  • I'm in the recovery environment- my laptop uses a "Novo button" instead of mashing a function key on boot, I chose "system recovery" on the menu that popped up. And I would do a backup. I really would. But I don't have another drive. I have my 500GB HDD that I was using, and a newer 240GB SSD that I want to move Windows to. As I'm currently ordering parts for a new PC, I'm looking for hardware anyway, so a backup disk may be a good investment...
    – jlc
    Feb 26, 2018 at 3:09
  • Could you run diskpart and list volume? Again, a photo would be useful.
    – Bob
    Feb 26, 2018 at 3:12

2 Answers 2

0

Your post only got my attention because it contains chromebook or another Chrome OS specific keyword on certain StackExchange sites. Chromebooks modified to run Windows is a very unusual case and therefore it's no surprise that other users will come up with recommendations that may not work for you. That's your mistake for not being explicitly clear about the situation from the start but putting this important information somewhere at the end. If you discover bug related to this kind of chromebook modification then the folks at r/chrultrabook are the only ones I know of who may have enough knowledge to help you out.

If anyone knows how to correctly get Windows to resize a partition, that would also be useful for the future. Yes, I disabled hibernation/pagefile/other stuff, and consolidated free space with Defraggler.

Use Windows' disk manager to resize the partition, if it refuses to do it then you have to reinstall or use dism (as Bob suggested in chat). More commands like bcdboot and reagentc may be required to run for troubleshooting instead of simply reinstalling, I tinkered with this on another problem here but at the moment I don't have a Windows booting chromebook nor sufficient time available to recreate your issue and look into it (to eventually learn something).

4
  • 1
    AFAICT the Chromebook is a separate (backup) device. The one with the issue was (?) a standard x86 laptop with dual-boot Windows and Ubuntu.
    – Bob
    Feb 27, 2018 at 1:15
  • 64-bit, and I just now realized how incredibly poorly phrased that part of my question was.
    – jlc
    Mar 7, 2018 at 0:17
  • Thanks for clarification. Were you able to solve your problem? I did not read the entire chat log just the last few lines today and it looks like you solved it.
    – LiveWireBT
    Mar 7, 2018 at 7:24
  • No. I did a clean install of Windows on a partition of the SSD. I was going to move everything besides the programs over to a separate partition on the HDD and leave them there anyways, and since they're still intact (save for some crucial startup file somewhere), I'm leaving them as they are for now. Perhaps I'll do something further when I have the rest of the parts for my PC, since I'll have 6 internal SATA ports instead of one.
    – jlc
    Mar 10, 2018 at 16:21
0

I used Ubuntu to rename LogonUI.exe to LogonUI.exe.bak, then I inserted a copy of LogonUI.exe from a working installation.
I figured this out because I got a few errors for LogonUI.exe when I wasn't specifically messing with that process.

I'm looking at the old desktop as I type this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .