56

I'm running Putty on Windows and can't find an option to increase the size of the scrollback buffer . It seems set at about 4 pages of text.

Am I missing something?

1

4 Answers 4

73

You can increase the scrollback by selecting the Window options category and changing the Lines of scrollback option.

4
  • i think it defaults to 200; when i configure a session profile for PuTTY on my systems i usually change this to 5000 or more. Apr 11, 2010 at 20:31
  • 2
    Ah! I was looking at the option nodes under Window, not realizing that Window itself has options :-)
    – Eric J.
    Apr 12, 2010 at 0:29
  • 1
    @quack: I can see how to save the config changes per session. Is there a way to save a new default for any session?
    – Eric J.
    Apr 12, 2010 at 0:35
  • 5
    @Eric: i'm pretty sure you can alter the config of the Default session in the same way you change it for any other session -- load the Default session, make your changes, save it as the Default session. Apr 12, 2010 at 0:59
10

First load the session, then go to the Window category in the left pane and change Lines of scrollback to say, 20000. Go back to the Session category and save it.

Note: you must load the session for it to save!

0
1

Its very simple load your required session and change your desired scroll back value on window option then click on Save button.

1
  • 2
    Can you clarify how this is different from the other two answers? Thanks.
    – fixer1234
    Apr 7, 2017 at 8:23
0

I was actually looking to increase the scroll-back buffer, but when starting a session from the windows terminal. For this, you need to change the default settings, like so :

To save your default settings: first set up the settings the way you want them saved. Then come back to the Session panel. Select the ‘Default Settings’ entry in the saved sessions list, with a single click. Then press the ‘Save’ button.

1
  • Oh, you're my rescue with this stubborn putty interface. Thanks!
    – it3xl
    Sep 26, 2021 at 2:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.