1

A friends windows 10 machine crashed and the hard drive now won't boot.

We took the hard drive and put it into my desktop. Booted linux, but we can't force mount the drive and the volumes don't come online by themselves. The drive is 1TB in capacity. It is a hybrid drive HDD/SSD.

Here is fdisk on /dev/sda: enter image description here

It only sees one sector on it.

enter image description here

Gparted doesn't see much either. Gparted says that it does not know the physical block size of the drive - 2048 bytes vs 512. I've read that it's impossible to recover data unless the software knows the correct block size.

gdisk didn't clarify things for me either: enter image description here

This is when I looked at disk management in windows, and the drive comes up as a protected GPT Partition enter image description here

What are the next steps to try? I've read there is software that claims to convert GPT Protective partition to MBR without data loss but I am skeptical about that.


UPDATE:


The drive is on disk 0 and the model is:

WD10S21X-24R1BT0-SSHD

I tried EaseUS partition manager to try and recover the partition table, but it does not see any partitions. I did not take any further action using easeUS. The automatic recovery of the regular easeUS program did not do much.

enter image description here

I also tried ZAR, and it failed to read any partitions on the drive as well. Since it does not know the size of the drive, it fails to create a meaningful disk image. When I manually specify 1024gb for the disk image, the image created off the drive comes out to only 512 bytes (0).

enter image description here

enter image description here

Minitool partition recovery can't seem to identify any partitions on the drive either:

enter image description here

1 Answer 1

1

Be sure not to use the disk without first processing a data recovery. That does include a hardware test.

ZAR (Zero Assumption Recovery), has a free image recovery button within its software. EaseUs allows for recovering 2G of data.

I would recommend replacing the drive, however if you are going to attempt to reuse it. After the files are recovered, you could format the drive or attempt a partition recovery. Once you are done be sure to test the disk before you attempt to use it again. An easy way is to right click the drive in my computer, select properties, tools than error checking. If it finds any issues a problem will likely reoccur with that drive within a short timeframe, maybe 6 or so months.

2
  • Hello David, thank you for the advice. I tried running ZAR and EaseUS and a few other software, none of which seem to be able to read or recover the partition table. All of the softwares are unable to detect the size of the drive. Mar 5, 2018 at 9:25
  • 1
    It appears that the disk has had a more significant failure since the first post. Normally when I see the issue from the second post, there is a failure in either the motor or the read arm. If the customer is willing to send this into a data recovery specialist like On-track or the manufacturer (Western Digital in this case). Stop here and send it out. If however they are not. You could try removing the little green board on it. Clean any connections on it (use a pencil eraser). Be careful with any pins and any cables. Again do NOT do this if they are wanting to send it into a recovery expert.
    – David Gill
    Mar 6, 2018 at 22:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.