3

1We have VDI in our company (cca. 50 Virtual Desktop Machines / Windows 10 / VMware Horizon View).

I have noticed that on all user machines process explorer.exe is using constantly cca. 20% of CPU (Thread shcore.dll!Ordinal247+0xc0 )

Explorer.exe shcore.dll

When I kill explorer.exe is all ok for several minutes, but then this problem appears again.

We have all latest Windows Updates on our VMs.

UPDATE 01.03.2018. -> Here is Screenshot from WPA for Analyze Screenshot from Explorer Stack from WPA

UPDATE 05.03.2018. -> Here are the settings for Taskbar. Taskbar settings

FIX 14.03.2018. -> Cursor Blink Rate setting CursorBlinkRateFIX

9
  • 1
    analyze cpu usage with WPR(UI) and WPA. Expand the stack of the explorer.exe which has the high Weight (%) Feb 28 '18 at 15:55
  • Thank you for your answer. I will do this today on one virtual machine and check it... If i would need help, can you please assist me then? I can send you what you need for analyzing... Thank you
    – Marin Loop
    Mar 1 '18 at 7:22
  • I have done it with WPRUI, but I have a problem with analyzing it... which process makes the problem. Can you please assist me? I have uploaded ETL file - I can send you the link for download. Thank you
    – Marin Loop
    Mar 1 '18 at 8:54
  • WPA picture shows that drawing 32Bit Icons (in Taskbar?) is causing the cpu usage. what are your taskbar settings (app grouping, small/large icons)? Which win10 build do you use (1607, 1703 or 1709)? And do you use last updates? Mar 1 '18 at 16:18
  • I have put the screenshot from our Taskbar settings above (screenshot). We are using Windows 10 Pro (Version 1709 / 16299.125). We are doing Windows Update every weekend.
    – Marin Loop
    Mar 5 '18 at 7:51
1

Under Control Panel -> Keyboard properties, the Cursor Blink Rate was set on "None" and after we changed it to somewhere in the middle -> problem is gone.

Screenshot of FIX

I don't know how/why, but this setting was problematic by us.

1
  • How did you reach the conclusion that this is the issue?
    – user398328
    Mar 2 '20 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.