4

I get a BSOD with stop code:

SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

on a clean windows install after enabling hyper-v.

The first time this has happened to me is when I installed docker for windows, which suggested that I enable Hyper-V. I selected ok, and then the laptop rebooted, and since then it didn't boot, giving out the same stopcode I mentioned.

I've reinstalled windows 10 and manually enabled Hyper-v, and ditto. I've reinstalled one more time, and again, ditto.

I've searched and read some posts online, but I have yet to come across a post that actually mentions a concrete fix on this issue -- I'm clueless right now.

  • I'm running Windows 10 Pro, and I have a separate physical drive that has Debian installed.
  • My laptop is LG Gram 2018 (15Z980) with i7-8550u.
  • I have the latest BIOS (2018-01-09)
  • I don't see a virtualization option in my BIOS.
  • systeminfo command says that my laptop is capable of running Hyper-V.

Edit:

  • Virtualization is enabled, despite the lack of an option at the bios. Running docker toolbox (virtualbox) or running kvm from debian gives me no problem.
  • I have checked the drivers and they were all up to date.
  • I am going to check with LG support to see if this is an issue specific to my laptop, or to this model.
  • You have to enable virtualization settings in the BIOS. I’m pretty sure this is the cause of the problem. You’ll have to keep looking. – Appleoddity Feb 28 '18 at 17:57
  • 1
    A lot of times it comes down to a buggy driver or the BIOS virtualization implementation. You may want to try rolling back a version of the BIOS. Also, verify that all your drivers are up to date. – essjae Feb 28 '18 at 18:43
  • 1
    If you are unable to enable VT-v within the firmware then you cannot use Hyper-V this also means you cannot use Docker. – Ramhound Feb 28 '18 at 19:30
1

15z980 BIOS has updated to K2ZC0250. You can update using LG DNA Center application. I just update that and Hyper-v Works Fine.

|improve this answer|||||
  • Unfortunately I still have the same problem after updating the firmware. – Haemin Yoo Apr 12 '18 at 4:38
  • I did have the same bsod after enabling Hyper-V. After a few unsuccessful automatic recovery attempts I was able to boot into safe mode. I actually didn't do anything except for backing up files -- but after that my laptop booted up just fine and I have Hyper-V enabled. How strange. – Haemin Yoo Apr 12 '18 at 4:59
-1

If you enable VT -x via BIOS you need to disable Hyper V. if still caused BSOD you need to disable Core Isolation. please go to https://www.teknokia.com/2019/09/how-to-fix-bsod-vt-x-virtualization-run-an-android-emulator-on-windows-10.html to disable it.

|improve this answer|||||
  • 1
    The author specifically is asking how to enable Hyper-V. An answer indicating they should keep it disabled is absolutely unhelpful – Ramhound Sep 1 '19 at 17:09
-2

The issue can be resolved by updating drivers through Windows Update.

|improve this answer|||||
  • 1
    You may want to improve your answer by adding more details. – Sandeep Jul 3 '18 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.